Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-17-2007, 12:22 AM   #1
satow
AF Newbie
 
Join Date: Sep 2007
Location: Toronto
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
stanza engine problem?

Hi,

I have a new problem on my stanza.
It was fine before I changed the oil, but after I changed the oil 2 days ago, and I can hear the engine making more noise than before. After one day of driving, I can hear some kind of weird noise i never heard before, it might sounds like high frequency sound, or maybe metal sounds. So i suspected it is caused by the oil used, but i bring it to another different shop, they don't notice it. So I leave it one more day, and drive a little more, now im sure the sound is there. One day ago, there is noise ONLY when i drive, but now i can hear the noise whenever i start the engine. It is kind of scary to drive when i think it is engin's metail is sliding each other without lubrication. So today, which is third day, i decided to add some more oil, and after a few tries, it does make the noise less, but still there once a while. I used this engine oil for many years, no problem on this same car.
So i go ahead and drive one more day, there is a new problem. The Red light for Engine oil is red lighted, first time i see it. As far as i know and asking some friends, it is for engine without enought oil. But I already added more oil, and I also checked it after it is cooled overnight, it HAS enough oil.... Another strange thing is the light is OFF when i drive it, and it goes on when i driving around 10km/h or slower, so around when i start to put gas, and when it is almost stopped. Now when i accelerating faster, i can see white smoke coming from the back, looks like it is burning engine oil to me.

Anyone know or what could happend, it is kind of strange.
So far i know the garage did a very bad job using bad oil, but this is first time in last 2 years with this garage. But what about the light and noise could be. Is it safe to even drive it to garage to complain and get it solved for free?



Thanks.
satow is offline   Reply With Quote
Old 09-17-2007, 02:15 AM   #2
curtis73
Professional Ninja Killer
 
curtis73's Avatar
 
Join Date: Nov 2002
Location: Penn Hills, Pennsylvania
Posts: 3,561
Thanks: 0
Thanked 9 Times in 9 Posts
Re: stanza engine problem?

The oil light you see is for oil pressure, not oil level. Something has happened that is allowing the oil pressure to drop. There are many reasons, like a leaking oil pickup tube, a clog in a certain oil passage, a stuck bypass, or other reason.

Stop driving it immediately until you figure it out. Right now you have a chance of not having damaged the engine but every minute you continue driving is one step closer to certain death.
__________________
Dragging people kicking and screaming into the enlightenment.
curtis73 is offline   Reply With Quote
Old 09-17-2007, 03:58 AM   #3
UncleBob
AF -Advisor
 
Join Date: Feb 2006
Location: Seattle, Washington
Posts: 1,482
Thanks: 0
Thanked 0 Times in 0 Posts
Re: stanza engine problem?

assuming your oil level really is OK, I would suspect the oil filter first

of course, the engine could be FUBAR'd, but its a cheap attempt, replacing the oil filter

cheap filters don't pay in the long run, in case that is the situation
__________________
life begins at 10psi of boost

Three turbo'd motorcycles and counting.
UncleBob is offline   Reply With Quote
Old 09-17-2007, 05:06 PM   #4
satow
AF Newbie
Thread starter
 
Join Date: Sep 2007
Location: Toronto
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: stanza engine problem?

So the light is for pressure, would too much engine oil make the pressure higher, and that light is on? Or Is it low on pressure wil make it on?

UncleBob : the oil filter changed at the same time the engine oil changed, so no need to change it again i guess?
satow is offline   Reply With Quote
Old 09-17-2007, 05:24 PM   #5
curtis73
Professional Ninja Killer
 
curtis73's Avatar
 
Join Date: Nov 2002
Location: Penn Hills, Pennsylvania
Posts: 3,561
Thanks: 0
Thanked 9 Times in 9 Posts
Re: stanza engine problem?

No, more oil doesn't make more pressure.
__________________
Dragging people kicking and screaming into the enlightenment.
curtis73 is offline   Reply With Quote
Old 09-17-2007, 06:21 PM   #6
UncleBob
AF -Advisor
 
Join Date: Feb 2006
Location: Seattle, Washington
Posts: 1,482
Thanks: 0
Thanked 0 Times in 0 Posts
Re: stanza engine problem?

the light comes on when the oil pressure in the main galley falls under a low psi (usually around 5psi)

This is the "oh sheit" light that should be translated to "SHUT OFF THE ENGINE THIS SECOND!"

Its not a sure thing that the motor is permanently damaged/completely destroyed....but its not a good thing if you have been running it like this for days with the light on.

But as I said, just replace the oil filter. Could be defective and is blocking flow, but I would suggest taking it to a shop to have them look it over. You don't sound terribly confident that you're checking the oil level correctly, and you are risking a junk motor. Its not worth the painfully expensive learning experience you're about to discover (assuming its not already too late)
__________________
life begins at 10psi of boost

Three turbo'd motorcycles and counting.
UncleBob is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:58 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts