Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Pontiac > Grand AM
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-13-2020, 11:22 PM   #1
Rubberman1
AF Newbie
 
Join Date: Sep 2020
Location: Evansville, Indiana
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
01 grand am crank but no start

Daughter was In drive thru when grand am started running rough then died. Had towed home. Scanner showed cylinder 1, 3 misfire and also B2965. This grand am has the 2.4l so I pulled the ignition cover, left plugged in and inserted plugs. Cranked car and all plugs sparked. When key turned forward I hear the fuel pump priming. I changed fuel pump last month so it has to be good. So I went the direction of the B2965 which is key in ignition open circuit. I replaced the ignition cylinder and didnít help. Today I replaced the ignition housing. Didnít work. The car already had the security mod to it so the security light goes out several secs after turning key forward. Scanner shows no more B2965 codes and also shows key in ignition with pass lock good. Iím at a loss of what else to look at. Car was running fine before it died.
Rubberman1 is offline   Reply With Quote
Old 09-14-2020, 12:47 AM   #2
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 5,649
Thanks: 6
Thanked 171 Times in 167 Posts
Re: 01 grand am crank but no start

Just because the pump is running doesn't mean injectors are firing. Just because you have spark doesn't mean it's firing correctly.

Unfortunately it's going to take further diagnosis. It could be physical timing out of whack. It could be ignition timing out of whack due to a cam sensor or something. It could be the injectors not firing due to a sensor failure.
__________________
Stealthee is online now   Reply With Quote
Old 09-14-2020, 06:36 PM   #3
Rubberman1
AF Newbie
Thread starter
 
Join Date: Sep 2020
Location: Evansville, Indiana
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 01 grand am crank but no start

for shits and giggles I swapped to the old pump to see how it would run. I noticed when I removed the fuel line from the pump there wasn't much pressure. Tried starting it and did nothing. So I swapped back to the new pump and still didn't have any pressure when removing the fuel line from pump. Read about the fuel pressure regulator and to remove the vac line from the top. did that and it started right but running rough. Did live data on scanner and showed cylinder 2, 3 with misfires. so I thought removing the fuel pressure reg and a coil pack should fix it
Rubberman1 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Pontiac > Grand AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:11 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts