Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Escape | Maverick | Escape Hybrid
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 04-09-2016, 07:36 PM   #1
imakedacookies
AF Regular
 
Join Date: Sep 2012
Location: Grover, Colorado
Posts: 142
Thanks: 5
Thanked 3 Times in 3 Posts
2012 Ford escape starting issues

Hey everyone, I bought a 2012 Ford Escape about two months ago. It is the limited 4x4 with the 4 cylinder. Out of nowhere Im having issues with it. It is having a very hard time starting, it cranks for a good 5 seconds, starts to sputter then I have to mash the gas to bring it to life. Once its on it runs just fine. There is also no correlation between the amount of time in between being on and how hard it is to start because sometimes its easier after I just ran it, other times it seems worse. Im really hoping it is just dirty injectors or something stupid like that. This problem started a week ago or so, so I havnt had any time to tinker with it, just been driving my truck instead. Also, I dont know if it has anything to do with it but it is also having electrical issues. My radio, ac/heater and anything in that console that has lights flicker on and off, my radio buttons on my steering wheel do completely random functions, my radio changes channels, inputs, and volumes when the car is started and my timer to keep the radio on after the car is shut off are not working. Im really confused if all of these things are connected or if my car is just a big problem. My main concern is the starting obviously, but any fixes to any of these problems would be awesome.
imakedacookies is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
electrical, issue, radio, starting
Go Back   Automotive Forums .com Car Chat > Ford > Escape | Maverick | Escape Hybrid

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:05 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts