Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Equinox
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-31-2022, 02:43 PM   #1
Scott2002SL2
AF Newbie
 
Join Date: Jun 2018
Location: Mora, Minnesota
Posts: 7
Thanks: 1
Thanked 2 Times in 2 Posts
Question '07 Equinox A/C has gone kaput. How to diagnose?



Some my '07 Equinox A/C has gone kaput. I's been working just fine all summer then suddenly the A/C button light started flashing slowly and the cold air went away.

It came on sporadically for a couple days and then would shut off and blow hot air.

I got out my gauges and hooked up to the low pressure port. The compressor was rapidly cycling and pressure was jumping high into the red and then into the blue as it cycled.

I turned of the system and checked all, I think all, the relays and fuses involved and all seem fine.

I released some pressure from the system and the lights, A/C and recirculate, stayed on and the compressor was engaging but not cooling and the pressure was showing very low.

With the system cranked up I added Freon to 55 lbs, it was 85F out, pressure gauge stayed steady at 55 lbs and the compressor stopped, lights wont come on, blower works and blows hot when set to hot and air temp when set to cool.

Now the pressure is at 55 lbs, car on or off, A/C requested or not. Fuses and relays all appear fine, compressor turns by hand but will not even try to engage when asked for cold air.

What the heck is going on? Compressor fried? Some mystery thing?

I saw somewhere I can't seem to find again there is a way to reset the system in cases like this.

Help anyone? Thanks in advance. Peace and Good Health.
Scott2002SL2 is offline   Reply With Quote
Old 08-01-2022, 06:25 AM   #2
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,304
Thanks: 5
Thanked 308 Times in 304 Posts
Re: '07 Equinox A/C has gone kaput. How to diagnose?

If you study the T/P curve for R134A, it may become apparent that the equalized pressure at 85F should be much closer to 95 PSIG, not 55.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Tags
a/c, clutch, freon
Go Back   Automotive Forums .com Car Chat > Chevrolet > Equinox

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:41 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts