Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Kia > Optima | Magentis | Lotze
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-13-2022, 09:56 PM   #1
jocago
AF Newbie
 
Join Date: Mar 2022
Location: Atlanta, Georgia
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Post Steering Wheel Heater

Hi. my 2013 Kia Optima hybrid was recently attacked by another car at a traffic light. Aside from the front-end damage (mainly the grill area was bashed in), I also noticed my steering wheel heater no longer worked. Since it was cold, I had been using it in the mornings so I know it worked a day or so prior to the accident. Afterward, though, it no longer turned on.

I pulled the fuse and replaced it with a spare, but that didn't change anything. It's hard for me to see how the wreck would have affected the steering wheel heater, especially since the body shop didn't find any weirdness or codes, but who knows? It's a hybrid.

Anyone have thoughts on how I could track this issue down?
jocago is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Kia > Optima | Magentis | Lotze

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:32 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts