Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Cavalier > Cavalier Problem Diagnosis
Cavalier Problem Diagnosis Got a problem you can't fix? We can help.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-04-2006, 06:22 PM   #1
snooprawb
AF Newbie
 
Join Date: Mar 2006
Location: Vancouver Island
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2003 Cavalier High Beams Not Working

My High beams for a 2003 cavalier are not working. I checked the bulbs and they are good, The Low Beams Work and my drls work. I switch from low to high and the blue indicator on the cluster panel comes on. Does anyone have any ideas on what the problem could be ???????????? plz help
snooprawb is offline   Reply With Quote
Old 12-19-2007, 10:17 PM   #2
bblomquist
AF Newbie
 
Join Date: Dec 2007
Location: Calgary
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Re: 2003 Cavalier High Beams Not Working

2002 cavalier same problem. Let me know what you find.
bblomquist is offline   Reply With Quote
Old 01-02-2008, 03:57 PM   #3
TonyP
AF Newbie
 
Join Date: Mar 2004
Location: Glenwood, New Jersey
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2003 Cavalier High Beams Not Working

My high beams just stopped working this morning. There are separate fuses for left and right not high and low, so it's not a fuse. Anyone with suggestions?
TonyP is offline   Reply With Quote
Old 01-02-2008, 04:17 PM   #4
bblomquist
AF Newbie
 
Join Date: Dec 2007
Location: Calgary
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Re: 2003 Cavalier High Beams Not Working

My girlfriends 2002 cavalier had a corroded high beam wire located near the connector under the battery. To get at it I had to remove the battery and the air filter box. The pink wire (high beams) was corroded so I just stripped the wire and soldered a new wire in where it was corroded. You can ohm out the wires easily by disconnecting the connector under the battery and ohm out the wires from that connector to the headlight connector.
bblomquist is offline   Reply With Quote
The Following User Says Thank You to bblomquist For This Useful Post:
kendq (12-23-2016)
Old 01-13-2008, 11:46 AM   #5
TonyP
AF Newbie
 
Join Date: Mar 2004
Location: Glenwood, New Jersey
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2003 Cavalier High Beams Not Working

I can see the connector but can't get to it. BTW the pink wire was already replaced by the dealer when I had a problem a while back.
TonyP is offline   Reply With Quote
Old 05-23-2012, 02:34 PM   #6
2000redsunfire
AF Newbie
 
Join Date: May 2012
Location: Columbus, Ohio
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2003 Cavalier High Beams Not Working

just a quick thank you to an old topic, followed pink back thru the harness below the battery (took out air box and battery) cut out of harness and ran a new wire to both headlights, and tada high beams again!!
2000redsunfire is offline   Reply With Quote
Old 12-23-2016, 02:09 PM   #7
kendq
AF Newbie
 
Join Date: Oct 2003
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 2003 Cavalier High Beams Not Working

Thanks to bblomquist my issue was the connector under the battery was corroded (2003 Cavalier)

Thanks again
kendq is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Cavalier > Cavalier Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:42 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts