Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Cutlass Series > N-Body Problem Diagnosis
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-16-2011, 01:35 PM   #1
charlie40
AF Newbie
 
Join Date: Oct 2007
Location: salem, Ohio
Posts: 59
Thanks: 2
Thanked 0 Times in 0 Posts
1990 3.3

i have a 90 cutless that idles rough and when put under load will not respond. sounds like it is starving. i have replaced fuel pump, plugs, wires,fuel press reg. when i turn on key i have fuel press for a aminute then it drops off. when i start the car it stays about 35 to 40 lbs. also replaced icm. any thoughts about what is next.?
charlie40 is offline   Reply With Quote
Old 10-16-2011, 07:30 PM   #2
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: 1990 3.3

See if it runs better with the MAF sensor disconnected....

Have you checked coil output with a spark tester?

Replace fuel filter?

Check for codes?
Tech II is offline   Reply With Quote
Old 10-23-2011, 10:03 AM   #3
charlie40
AF Newbie
Thread starter
 
Join Date: Oct 2007
Location: salem, Ohio
Posts: 59
Thanks: 2
Thanked 0 Times in 0 Posts
Re: 1990 3.3

got it replaced fuel rail and injectors runs great. thanks for looking
charlie40 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
1990 lumina3.1 Euro starts cold, runs ok until stop engine, then wont restart bigtimmy45 Lumina 1 06-19-2010 11:39 AM
1990 Buick Century 3.3 Won't Idle bell345 Century 8 04-12-2005 06:34 PM
1990 3.3 rough running until wamed up wrenchead90 Caravan | Voyager 7 01-20-2004 08:42 AM
1990 3.3 rough running until wamed up wrenchead90 Caravan | Voyager 0 11-10-2003 11:04 PM
1990 3.3 Won't start... Xodus921 Caravan | Voyager 1 10-28-2003 07:37 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Cutlass Series > N-Body Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:32 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts