Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-15-2018, 09:41 AM   #1
elamp6
AF Newbie
 
Join Date: May 2018
Location: Dallas, Texas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question Windshield wipers barely working on high?

My windshield wipers work perfectly when I have them on low/intermittent, but when I bump them up to high, they struggle to get across the windshield. At first I thought it might be the motor, but given that they work fine on low, I'm thinking it could be the switch..?

Any insight would be super helpful. I'm very much a beginner when it comes to all things cars, but would love to be able to diagnose and fix this myself, if possible, to save some cash!
elamp6 is offline   Reply With Quote
Old 05-15-2018, 09:48 AM   #2
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,336
Thanks: 1
Thanked 142 Times in 138 Posts
Re: Windshield wipers barely working on high?

Make model year would be nice to know.
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
Old 05-15-2018, 11:21 AM   #3
elamp6
AF Newbie
Thread starter
 
Join Date: May 2018
Location: Dallas, Texas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Windshield wipers barely working on high?

Quote:
Originally Posted by aleekat View Post
Make model year would be nice to know.
2010 Suzuki Kizashi
elamp6 is offline   Reply With Quote
Old 05-15-2018, 11:38 AM   #4
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,336
Thanks: 1
Thanked 142 Times in 138 Posts
Re: Windshield wipers barely working on high?

I would suspect the motor. But I would join over at this club dedicated to your car.
https://www.kizashiclub.com/forum/in...d46db88dfaebc5
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
Old 05-24-2018, 08:37 PM   #5
BerserkerInd
AF Newbie
 
Join Date: May 2018
Location: Raleigh, North Carolina
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Either the wiper motor or potentially an alternator issue. When you turn it on high, do you notice any dash lights dimming or anything?


Sent from my iPhone using Tapatalk
BerserkerInd is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
motor, suzuki, windshield, wiper, wipers
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:48 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts