Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Eclipse/Talon/Laser > Off-Topic
Off-Topic Talk about anything other than cars.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-08-2004, 09:33 AM   #1
shahram177
AF Newbie
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Help Help Help!!!!! Need Help!

TRANNY FLUID FOR A MT 96 ECLIPS NT FWD!
What type of Red Line should i use?
should i use Red Line?

HELP HELP HELP!
for some dumb stupid reason when the car turns on i hear a horrid barring noise comming from the tranny when the car is in nural and the clutch is up!
so i'm changing my tranny flid, the car has 140k, but i have no clue what flid to put in!
i talked to the dealer and all they have is avaliabele in 5 gallon buckets!


HELP HELP HELP!
shahram177 is offline   Reply With Quote
Old 11-08-2004, 10:05 AM   #2
shahram177
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

guys i really really ned some help here! any one!
i'm about to go off and buy the red line tranny fluid.
is that ok?
i'm going to get the fluid in a few
http://redlineoil.com/
i'm going to get the MTL stuff!
what does every one think!
shahram177 is offline   Reply With Quote
Old 11-08-2004, 10:21 AM   #3
shahram177
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

mates i could really use some help here!
can i use the redline gear oil yes or no?
shahram177 is offline   Reply With Quote
Old 11-08-2004, 10:42 AM   #4
spyderturbo007
AF Enthusiast
 
spyderturbo007's Avatar
 
Join Date: Mar 2004
Location: Camp Hill, Pennsylvania
Posts: 1,634
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

I have heard good things about redline fluid, all you have to do is find out exactly what weight fluid your NT calls for. You should be able to check the owners manual for that information or contact your local auto parts store.

On a side note, you don't have to post three times in a row inside of 50 minutes, someone will answer your question as soon as they get a chance.
__________________


1997 Spyder GS-T
5-Speed
EVO III 16g, DSMLink, Walboro 190 lph Fuel Pump, FIC 650cc injectors, CoolingMist 150psi Methanol Injection, Greddy EVO 2 Cat Back, 2.5" Extreme DP, 2.5" Extreme Hi-Flow Cat, Injen intake, HyperDrive C1 Street Disk & PP, HyperDrive Lightweight Flywheel, 1g BOV, RRE UICP, Home Depot MBC, AEM UEGO WBO2, Brembo Slotted rotors, Akebono Ceramic Pads
spyderturbo007 is offline   Reply With Quote
Old 11-08-2004, 10:47 AM   #5
shahram177
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

sorry mate just going nuts here thats all.
Sorry
Shah D
shahram177 is offline   Reply With Quote
Old 11-08-2004, 10:52 AM   #6
shahram177
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

ok just figired it out! but not happy.
apparently Mitsubitchi uses two types of gear lube and its vin code dependent. Who the heck do these guys think they are BMW!
well any way, here is the dea, FYI
look at you vin, if the 8th character is Y then you need chrystler gear lube!
WTF!
ah well life goes on i guess.
shahram177 is offline   Reply With Quote
Old 11-08-2004, 12:41 PM   #7
shahram177
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

so here is another dumass design flaw in our cars.
ok where are all the bearings located? on the top.
where is the fill line? lower than the bearing!
how the hell does the oil get to the bearings?
shahram177 is offline   Reply With Quote
Old 11-08-2004, 01:22 PM   #8
scottsee
AF Enthusiast
 
Join Date: Mar 2004
Location: spokane, Washington
Posts: 3,681
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to scottsee
Re: Help Help Help!!!!! Need Help!

you are aware you can "edit, delete" your own threads and posts right? so you can add to what you allready typed when new information presents itself...
__________________
DSM geek
scottsee is offline   Reply With Quote
Old 11-08-2004, 01:27 PM   #9
shahram177
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

just descovered how to do it!
shahram177 is offline   Reply With Quote
Old 11-08-2004, 02:35 PM   #10
WankelTII
AF Regular
 
Join Date: Nov 2003
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

sounds to me like your problem is your throw out bearing, and that is only like $30 but its between your engine and tranny so tranny has to come out. You might want to just live with a loose TOB for a while as long as its shifting fine and it doesnt sound like suff is gonna explode. If it sounds really that bad then you should replace it, and probably the clutch to if you were planning on doin it ever. Try the tranny fluid i guess but you will have to change it again when the tranny comes out. I dont remember if there is a drain for it or not, but there is a hole with a bolt in it on the side of the tranny under the car, i forget which side but it is easy to spot, you take it out and either drain or pump out old fluid and put in new, just fill to bottom of hole.
WankelTII is offline   Reply With Quote
Old 11-08-2004, 02:41 PM   #11
shahram177
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

I thought it was the throw bearing but the sound is comming from the upper left corner of the tranny.
i know that eventually have to change the clutch.
its the origional one! and i have 140K on it!
maybe the fluid will help it. if not then well...what can you do?
but i doubt that its the throw bearing, the clutch works verry well. maybe its the tranny? maybe its just shot!
shahram177 is offline   Reply With Quote
Old 11-09-2004, 12:51 AM   #12
WankelTII
AF Regular
 
Join Date: Nov 2003
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

Well try the fluid, but my TOB made a crap load of racket before i replaced it and i never noticed a difference in driving the car untill the springs in the clutch broke. (these 2 things not related, both just old) and i couldnt tell where it was coming from, except that it was definately in the tranny, but i knew what it was right away. There isnt a whole lot of stuff in a manual transmition that can make that noise. And if your fluid was bad or had leaked out or something, you would notice it more in shifting and the feel of the stick, it would feel rough and the syncros would be having trouble doing their job and probably whine alot. Is the tranny doing what its suppose to do, even if it grinds every now and then (that could just be a bad syncro in one gear or you dont know how to shift or something) If it is going it all gears with no trouble, then the tranny is fine.
WankelTII is offline   Reply With Quote
Old 11-09-2004, 08:22 AM   #13
shahram177
AF Newbie
Thread starter
 
Join Date: Dec 2003
Location: Flanders, New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Help Help Help!!!!! Need Help!

Yah maybe it is the TOB,
but i'm guessing the flid has just gone bad.
I bought the car at 90k and now it has 140k I replaced the fluid when i bought the car so its been a while. And i don't drive the car mutch. only to and from work, about 10k miles a year.
so it spends alot of its time sitting and that can't be verry good for bearings!
So how much did it cost to have the TOB replaced?
and im guessing if you are replacing the TOB you should naturally replace the clutch as well right?
well any way thank you so much for the help!
shahram177 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Mitsubishi > Eclipse/Talon/Laser > Off-Topic

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:25 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts