Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Mustang > Mustang Problem Diagnosis
Mustang Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 04-17-2013, 04:45 PM   #1
Charlie H
AF Newbie
 
Join Date: Apr 2013
Location: Terre Haute, Indiana
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
96 mustang GT 4.6L - no start

96 Mustang GT: Was running fine. Parked for 2 hours. Now cranks but NO START. Occasional "pop" as if trying.

Had leaky fuel pressure regulator - replaced. Replaced Crank and Cam sensors. HAVE spark at all plugs and fuel at fuel rail (pressure = ~38 psi). Injectors ARE firing (checked with noid light). Theft light turns off after 3 sec.

What am I missing? Any ideas appreciated.

Thanks.
Charlie H
Charlie H is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Tags
4.6, problem, starting
Go Back   Automotive Forums .com Car Chat > Ford > Mustang > Mustang Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:34 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts