Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Nissan > Altima
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-04-2019, 01:42 PM   #1
hutskob
AF Newbie
 
Join Date: Nov 2012
Location: Dallas, Texas
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2009 stutters at idle/low RPM. Again.

I have a 09 Altima 2.5L with 190k, CVT. About 6 months ago, I was on the way to the fuel station when it started stuttering badly. I thought I was about to run out of gas. I made it to the station, filled it, but the problem only got worse as I continued down the road. I stopped driving and took it to the shop 2 days later. The stutter would occur at idle, but the idle stayed at stable RPM. If accelerator was depressed lightly, it would get worse and power was limited. However, if I stomped it, the stutter would stop and I would regain power.

The shop told me my valves needed cleaning/replacing. A good amount of $ later, the car runs fine and has until today. On my way home today, it started again. Same exact issue. The idle is about 700, consistent but rough. The acceleration is sluggish and feels like a cylinder is mis-firing. If I floor it, it accelerates normally.

I already had made an appointment on Monday for an oil change and state inspection. I don't think another valve job will correct the problem, so does anyone have any ideas as to what this could be? TPS? Exhaust O2 sensor? I'm hesitant to spend another 1k+ to have this happen again in 6 more months.

Thanks for any ideas

Last edited by hutskob; 10-04-2019 at 01:44 PM. Reason: mis-spelling
hutskob is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Nissan > Altima

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:48 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts