Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mercury > Villager
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-10-2011, 10:10 PM   #1
moshawh101
AF Newbie
 
Join Date: May 2011
Location: osakis, Minnesota
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
mercury villager 1999 random multiple cylinder misfire

I have a 1999 mercury villager that is showing a random multiple cylinder misfire code and an o2 sensor code. The vehicle has a small leak on the exhaust between the catalytic converters and I'm not sure if this would be affecting the back pressure enough to make the engine throw these codes. Also I replaced the distributor and tried the original placement of the distributor and multiple placements. I am going to get the exhaust fixed and put either b12 cleaner/ seafoam cleaner through the engine and fuel system to see if anything will clear up the fuel system/ make it slightly better. The vehicle runs rough at an idle but runs smooth when reving and at higher speeds above approx 1300+RPM's. Are there any other explanations to why it would be running rough?
moshawh101 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
Random/Multiple Cylinder Misfire Riverdog07 Cavalier Problem Diagnosis 5 11-05-2007 12:32 AM
P0300-Random/Multiple Cylinder Misfire questions-Please help! quicky422 Alero 3 07-10-2007 05:23 PM
Random/multiple cylinder misfire Silverado Brethern C/K 13 12-13-2005 06:29 PM
Random/Multiple cylinder misfire insanesnwbrdr Camaro Discussions 2 11-17-2005 09:49 PM
random multiple cylinder misfire rwp212 Cavalier 2 06-25-2005 12:02 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
cylinder, misfire, multiple, random
Go Back   Automotive Forums .com Car Chat > Mercury > Villager

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:21 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts