Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Eclipse/Talon/Laser > Eclipse Problem Diagnosis
Eclipse Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-18-2013, 12:48 AM   #1
drkPu1se
AF Newbie
 
Join Date: Feb 2013
Location: Greenland, New Hampshire
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
1999 Eclipse sounds like a popcorn machine

Hi all!

I just bought a 1999 Mitsubishi Eclipse RS 4 cyl 2.0L. I don't know what got me to buy it but I don't want to get rid of it. It is all sorts of trashy but now that I have it, might as well make into a nice project car right?

Well here's what I have as an issue right now... it misfires and stutters when accelerating. I took it to Advanced Auto Parts and got codes that say cylinders 2 and 3 are misfiring. I replaced the spark plugs with Autolites temporarily to see if that was the problem. I got a lot more power but it still misfires. I also found out that the previous owner was using a lower octane fuel to fill it up so I completely emptied out the gas tank and filled it up with premium fuel. Again runs even better but still sounds like a little popcorn machine. I bought some spark wires but haven't installed them yet due to the weather. I hate the snow. Another reason I haven't installed them yet is because one of the guys at Advanced Auto said that there could be a potential issue with the carburetor? That didn't sound at all right but what do I know. I am not exactly car smart at all. This is my second car, my previous one smashed to smithereens by some old woman. Anyways... opinions anyone?

I'm also using this forum as a 'gateway' to learn more about automotives. It's perfect for it seeing that there is noticeable electrical and possible engine issues. I got the car dirt cheap so why not right?

Anyways, Thanks in advance!!
drkPu1se is offline   Reply With Quote
Old 02-18-2013, 06:09 PM   #2
SilvrEclipse
Holset powered 420a
 
SilvrEclipse's Avatar
 
Join Date: May 2005
Location: Florence, South Carolina
Posts: 4,434
Thanks: 1
Thanked 14 Times in 12 Posts
Send a message via AIM to SilvrEclipse
Re: 1999 Eclipse sounds like a popcorn machine

Welcome to AF

It sounds like your off to a good start doing a few maintenance items to eliminate possible issues. Plugs and wires are a good start. Did the check engine light come back on once they cleared the codes? Sometimes its good to get them to clear the codes and then get them rechecked if it comes back on, some codes could be from previous problems that were never cleared.

I would start by checking the wiring going to the injectors and the coil pack. Especially around the EGR tube on the right side of the head. Does the car miss at idle or only under certain load conditions?
__________________
98 Eclipse GS Turbo
Megasquirt 2 - Holset HY35 Turbo - Built motor - P&P Head and Intake - 3" Turbo back - FMIC - Greddy RZ BOV - Walbro 255 - Aeromotive AFPR - 650cc Injectors - Fidanza Flywheel - Zoom clutch - 13" Cobra Front Brakes - AEM WB - Devilsown meth injection - 3.55 Final Drive gear ratio

1981 Chevy Scottsdale
1987 Nissan 300zx - Chump Car
2001 BMW 325i - DD
SilvrEclipse is offline   Reply With Quote
The Following User Says Thank You to SilvrEclipse For This Useful Post:
drkPu1se (04-06-2013)
Old 02-18-2013, 07:18 PM   #3
drkPu1se
AF Newbie
Thread starter
 
Join Date: Feb 2013
Location: Greenland, New Hampshire
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 1999 Eclipse sounds like a popcorn machine

Quote:
Originally Posted by SilvrEclipse View Post
Welcome to AF

It sounds like your off to a good start doing a few maintenance items to eliminate possible issues. Plugs and wires are a good start. Did the check engine light come back on once they cleared the codes? Sometimes its good to get them to clear the codes and then get them rechecked if it comes back on, some codes could be from previous problems that were never cleared.

I would start by checking the wiring going to the injectors and the coil pack. Especially around the EGR tube on the right side of the head. Does the car miss at idle or only under certain load conditions?

I was actually going to see about the coil pack tomorrow. As for car missing, it misses when accelerating. And it doesnt catch speed at all well. I also think it has something to do with the horrible cold weather. Heh. We'll see tomorrow
drkPu1se is offline   Reply With Quote
Old 02-19-2013, 05:09 PM   #4
SilvrEclipse
Holset powered 420a
 
SilvrEclipse's Avatar
 
Join Date: May 2005
Location: Florence, South Carolina
Posts: 4,434
Thanks: 1
Thanked 14 Times in 12 Posts
Send a message via AIM to SilvrEclipse
Re: 1999 Eclipse sounds like a popcorn machine

And by the way the non turbo models do not need to run premium fuel. You are safe to run 87 octane
__________________
98 Eclipse GS Turbo
Megasquirt 2 - Holset HY35 Turbo - Built motor - P&P Head and Intake - 3" Turbo back - FMIC - Greddy RZ BOV - Walbro 255 - Aeromotive AFPR - 650cc Injectors - Fidanza Flywheel - Zoom clutch - 13" Cobra Front Brakes - AEM WB - Devilsown meth injection - 3.55 Final Drive gear ratio

1981 Chevy Scottsdale
1987 Nissan 300zx - Chump Car
2001 BMW 325i - DD
SilvrEclipse is offline   Reply With Quote
Old 03-03-2013, 06:33 AM   #5
drkPu1se
AF Newbie
Thread starter
 
Join Date: Feb 2013
Location: Greenland, New Hampshire
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 1999 Eclipse sounds like a popcorn machine

Quote:
Originally Posted by SilvrEclipse View Post
And by the way the non turbo models do not need to run premium fuel. You are safe to run 87 octane
Woot the popcorn is gone and my Eclipse doesn't lose power on the highway anymore! Turns out I kept getting bad wires until now. Now for the part that stumps me... apparently there are still misfires going. I don't feel or hear anything though. Not that I know much of it because I'm not exactly car smart... I reread your post because I remember you mentioning something else. Where and how would I check EGR tube and coil packs? As the for the misfires... my check engine light blinks when I idle at a stop. a friend of mine mention this might have to do with my AC compressor/ power steering belt. I removed it because my tensioner pulley fell completely off. Stripped bolt... my doing. I ordered a whole new tensioned assembly because why not replace the whole setup- the old tensioner assembly was slightly rusty (I live right on the coast). could that have anything to do with the idling? I have my doubts as it doesn't sound too logical to me...
drkPu1se is offline   Reply With Quote
Old 03-03-2013, 08:41 PM   #6
SilvrEclipse
Holset powered 420a
 
SilvrEclipse's Avatar
 
Join Date: May 2005
Location: Florence, South Carolina
Posts: 4,434
Thanks: 1
Thanked 14 Times in 12 Posts
Send a message via AIM to SilvrEclipse
Re: 1999 Eclipse sounds like a popcorn machine

The check engine light should only flash if there is a big problem that is currently occuring and needs attention, Im not even sure if the 420a ECU has this function, but I have been it on many other cars so its possible. Just something I havent seen before. The PS or AC belt wouldnt cause this issue. I would get the codes pulled and see what the problem is. At least you are making progress.
__________________
98 Eclipse GS Turbo
Megasquirt 2 - Holset HY35 Turbo - Built motor - P&P Head and Intake - 3" Turbo back - FMIC - Greddy RZ BOV - Walbro 255 - Aeromotive AFPR - 650cc Injectors - Fidanza Flywheel - Zoom clutch - 13" Cobra Front Brakes - AEM WB - Devilsown meth injection - 3.55 Final Drive gear ratio

1981 Chevy Scottsdale
1987 Nissan 300zx - Chump Car
2001 BMW 325i - DD
SilvrEclipse is offline   Reply With Quote
Old 03-04-2013, 06:07 AM   #7
drkPu1se
AF Newbie
Thread starter
 
Join Date: Feb 2013
Location: Greenland, New Hampshire
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 1999 Eclipse sounds like a popcorn machine

Quote:
Originally Posted by SilvrEclipse View Post
The check engine light should only flash if there is a big problem that is currently occuring and needs attention, Im not even sure if the 420a ECU has this function, but I have been it on many other cars so its possible. Just something I havent seen before. The PS or AC belt wouldnt cause this issue. I would get the codes pulled and see what the problem is. At least you are making progress.
Agreed on the progress, but now I'm a bit worried. It has been flashing since I got the Eclipse. whenever I do pull the codes all I get is misfires. I'm probably just going to have my mechanic take it for a couple of days and work something out. Will update when I can.
drkPu1se is offline   Reply With Quote
Old 04-06-2013, 03:09 PM   #8
drkPu1se
AF Newbie
Thread starter
 
Join Date: Feb 2013
Location: Greenland, New Hampshire
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 1999 Eclipse sounds like a popcorn machine

Hi again! Just an update.... the popcorn has stopped completely! I think it has something to do with the warm weather... anyways.. the popping only happens when I gas it around tight corners.

Here's the new concern of my car - not sure if I should just put this in another tag.. - again I am car illiterate, but here's my personal diagnosis. My Eclipse will now feel like there is grinding when taking off, and doesn't shift right. I've already caught crap about it, but my Eclipse is an automatic, and my personal diagnosis about the grinding is it has something to do with my transmission. One of my friends told me that stock automatic Eclipses receive transmissions that go to crap after about 60k miles. Well.... I just turned it to 164k literally this morning.

Anyways, that's my next issue I want to address. After that's figured out, I want to find out what the heck the previous owner did with the wiring in it... The stereo is definitely not wired to the ignition switch. Killed my battery once already. I just tore the stereo out until I can find out how to fix that... Again, car illiteracy is in me haha!

Thanks for the help!
drkPu1se is offline   Reply With Quote
Old 08-21-2013, 07:38 AM   #9
ColtonW
AF Newbie
 
Join Date: Aug 2013
Location: Faust
Posts: 24
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 1999 Eclipse sounds like a popcorn machine

what type of grinding does it make? haha two months late but hey, I just joined here. like where do you hear it the most?? <-- try changing trans fluids.. helps alot..
ColtonW is offline   Reply With Quote
Old 08-22-2013, 02:54 PM   #10
SilvrEclipse
Holset powered 420a
 
SilvrEclipse's Avatar
 
Join Date: May 2005
Location: Florence, South Carolina
Posts: 4,434
Thanks: 1
Thanked 14 Times in 12 Posts
Send a message via AIM to SilvrEclipse
Re: 1999 Eclipse sounds like a popcorn machine

Quote:
Originally Posted by ColtonW View Post
what type of grinding does it make? haha two months late but hey, I just joined here. like where do you hear it the most?? <-- try changing trans fluids.. helps alot..

Yea you need to investigate where the noise is coming from more. Open the hood and have someone walk beside the car while you drive it to try and narrow it down. I wouldnt change the tranny fluid in that car. With that many miles on the tranny its going to slip and die if you change it out.
__________________
98 Eclipse GS Turbo
Megasquirt 2 - Holset HY35 Turbo - Built motor - P&P Head and Intake - 3" Turbo back - FMIC - Greddy RZ BOV - Walbro 255 - Aeromotive AFPR - 650cc Injectors - Fidanza Flywheel - Zoom clutch - 13" Cobra Front Brakes - AEM WB - Devilsown meth injection - 3.55 Final Drive gear ratio

1981 Chevy Scottsdale
1987 Nissan 300zx - Chump Car
2001 BMW 325i - DD
SilvrEclipse is offline   Reply With Quote
The Following User Says Thank You to SilvrEclipse For This Useful Post:
ColtonW (08-28-2013)
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
accelerating, misfire, plugs, repair, spark
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Eclipse/Talon/Laser > Eclipse Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:50 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts