Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Blazer > Problem Diagnosis
Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-10-2009, 04:43 PM   #1
christian1218
AF Newbie
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
S-10 Blazer stalls when engine is hot

I have a 92' s-10 Blazer with the 4.3 TBI vortec engine 4x4. The problem im having is that she runs fine till she is hot then when you come to a stop or a slow drive she will stall but if you take it out on the highway it runs great again. Just the low RPM's she will stall but only when engine is hot. Ive had the computer read and there are no codes. I've changed bad vacum lines, fuel filter, spark plugs, and spark plug wires. any help is appriciated thanks.
christian1218 is offline   Reply With Quote
Old 10-11-2009, 09:01 AM   #2
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by christian1218 View Post
I have a 92' s-10 Blazer with the 4.3 TBI vortec engine 4x4. The problem im having is that she runs fine till she is hot then when you come to a stop or a slow drive she will stall but if you take it out on the highway it runs great again. Just the low RPM's she will stall but only when engine is hot. Ive had the computer read and there are no codes. I've changed bad vacum lines, fuel filter, spark plugs, and spark plug wires. any help is appriciated thanks.
Is it stalling from low engine RPM.

What is engine rpm in park and drive engine hot?
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-11-2009, 09:23 AM   #3
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

Things to check are dirty or bad IAC valve or pcv valve and or egr valve sticking open.
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-11-2009, 01:13 PM   #4
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

The truck doesnt have an RPM gauge. Its an automatic. But usually any speed under 25 mph and she will stall when the engine is hot. Im about to check the fuel pressure in the next couple of days to rule out that. as far as the EGR valve how do you check if its sticking? Because it seems to have good range of motion when i move the throttle while engine is off.
christian1218 is offline   Reply With Quote
Old 10-11-2009, 04:34 PM   #5
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

Vacume or electronic egr valve?
On egr valve pull it when it is dying and see if carbon is sticking it open.
Any check engine lifghts on?
Is the idle good hot in park or when you put in gear foot on brake?
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-11-2009, 05:50 PM   #6
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

its a vacume egr. There are never any check engine lights or codes on computer. It only idles good untill the engine gets hot. When the engine is hot it doesnt matter if its in park or drive or neutral all 3 ways it will be very eratic and want to die. Ill try to pull on egr when its dying. the problem is i have to drive it for 10-15 mins till it runs badly and im usually by myself.
christian1218 is offline   Reply With Quote
Old 10-12-2009, 08:10 AM   #7
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by christian1218 View Post
its a vacume egr. There are never any check engine lights or codes on computer. It only idles good untill the engine gets hot. When the engine is hot it doesnt matter if its in park or drive or neutral all 3 ways it will be very eratic and want to die. Ill try to pull on egr when its dying. the problem is i have to drive it for 10-15 mins till it runs badly and im usually by myself.
You need to get a scanner on it and check IAC valve opeation.

But try unpluging iac valve and egr valve when cold engine running and idling good.

Then see if it goes to pot after warm up.
Post back what you find.
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-12-2009, 08:54 AM   #8
TCGrove
AF Newbie
 
Join Date: Jan 2007
Location: Washington CH, Ohio
Posts: 98
Thanks: 1
Thanked 1 Time in 1 Post
Re: S-10 Blazer stalls when engine is hot

How many miles are on it? I've had many if not all the problems that many people post with my 99 Blazer 4x4 with 155,000 miles. For two years now I've had trouble with the thing losing power when going to accelerate, rough idle (especially when stopping), etc. I've changed fuel filters, pump, rotor, wires, plugs, cleaned MAF...but just recently did one that worked miracles.... I changed my O2 Sensors. I tested the one with an ohm meter and propane torch (there's two of them to replace) and found the voltage to be all over the place. I guess these things do wear out. My Blazer runs great now...even better gas milage (if you call 18.4 mpg better than 17 mpg haha). O2 sensors don't read until they hit something like 600 F. The voltage then swings from 0.1 to 0.9 volts and adjusts your fuel to air ratio to hit 1 : 14.7 or something like that. Just some food for thought if your having trouble once the engine heats up.
TCGrove is offline   Reply With Quote
Old 10-12-2009, 09:58 AM   #9
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by MT-2500 View Post
You need to get a scanner on it and check IAC valve opeation.

But try unpluging iac valve and egr valve when cold engine running and idling good.

Then see if it goes to pot after warm up.
Post back what you find.



I will try this but to tell you the truth i dont know where the idle air control valve is located or how to diconnect also with the egr do i remove the vacum lines? and should i plug them whne trying this?
christian1218 is offline   Reply With Quote
Old 10-12-2009, 10:16 AM   #10
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by christian1218 View Post
I will try this but to tell you the truth i dont know where the idle air control valve is located or how to diconnect also with the egr do i remove the vacum lines? and should i plug them whne trying this?
Iac valve is on the TBI.
About 4 wire square plug in .

Just unplug the vacuum hose on egr valve,
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-12-2009, 01:37 PM   #11
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

i tried to unplug the iac and egr vacume hoses. at just idling it was fine. but pluged both back in and drove for 10 mins and slowed down and it died. then just unpluged vacume line off egr and still died, pluged vacume lines back in and unpluged iac connector and it doesnt die but idles really high.
christian1218 is offline   Reply With Quote
Old 10-12-2009, 02:21 PM   #12
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by christian1218 View Post
i tried to unplug the iac and egr vacume hoses. at just idling it was fine. but pluged both back in and drove for 10 mins and slowed down and it died. then just unpluged vacume line off egr and still died, pluged vacume lines back in and unpluged iac connector and it doesnt die but idles really high.
Sounds like pcm is not controling IAC or iac valve is not working right.

You need to get it on a engine capable scanner and check out IAC valve and iac control.
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-12-2009, 05:35 PM   #13
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by MT-2500 View Post
Sounds like pcm is not controling IAC or iac valve is not working right.

You need to get it on a engine capable scanner and check out IAC valve and iac control.



What is the PCM and where would it be located? Where would one find an engine capable scanner?
christian1218 is offline   Reply With Quote
Old 10-12-2009, 05:38 PM   #14
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by christian1218 View Post
What is the PCM and where would it be located? Where would one find an engine capable scanner?
The PCM is powertrain control module/computer.
Most good repair shops have the engine capable scanners.
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-12-2009, 08:11 PM   #15
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

so i made an appointment on friday to look at her. They say they are gonna do fuel press test, injector test, starter test, alenoid? test, and computer check. Maybe more. i dont know. but still plan on tryin more till then because they say $75- $175 to look at it.
christian1218 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
s-10, stalls
Go Back   Automotive Forums .com Car Chat > Chevrolet > Blazer > Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:14 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts