Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Blazer > Problem Diagnosis
Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-13-2009, 04:54 PM   #16
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by MT-2500 View Post
The PCM is powertrain control module/computer.
Most good repair shops have the engine capable scanners.

could all this be from the vacume line on the master cylinder? Because on the master cylinder the connector that conects the vacume line to the master cylinder is a round connector that is wiggly and i dont know if they all feel like that.
christian1218 is offline   Reply With Quote
Old 10-13-2009, 04:58 PM   #17
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

could all this be from the vacume line on the master cylinder? Because on the master cylinder the connector that conects the vacume line to the master cylinder is a round connector that is wiggly and i dont know if they all feel like that.
christian1218 is offline   Reply With Quote
Old 10-13-2009, 05:46 PM   #18
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

You can pull it and plug vacuum line for a test.
But you will have very little brake.
So do not drive it plugged.
Just for a test.
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-13-2009, 05:57 PM   #19
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

well i pulled it off and could hear air leaking out while doing it and i havent drove it since yesterday so i think its probally holding good pressure. And the valve in the connector still has spring action so its probally good right? Also its virtually impossible to recreate the problem while not on a test drive. i tried for like an hour yesterday while parked, and ran it the entire time with out a problem but as soon as your driving for 10-15 mins then the problem is there.
christian1218 is offline   Reply With Quote
Old 10-13-2009, 06:15 PM   #20
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by christian1218 View Post
well i pulled it off and could hear air leaking out while doing it and i havent drove it since yesterday so i think its probally holding good pressure. And the valve in the connector still has spring action so its probally good right? Also its virtually impossible to recreate the problem while not on a test drive. i tried for like an hour yesterday while parked, and ran it the entire time with out a problem but as soon as your driving for 10-15 mins then the problem is there.
Valve spring action does not mean much.

If you can not hear vacuum leak at it with brake on or off.
And it does not change idle with it pulled and plugged it should be good.
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-13-2009, 07:51 PM   #21
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

Quote:
Originally Posted by MT-2500 View Post
Valve spring action does not mean much.

If you can not hear vacuum leak at it with brake on or off.
And it does not change idle with it pulled and plugged it should be good.

Well i changed the IAC valve and then drove it on the highway for 17 miles then had to slow down for an off ramp and it stalled again. It would not start for about 20 mins. Just turns over but no fire. Usually it will atleast try to fire. I then pulled off the vacume line off the master cylinder and pluged the hole and no change, reatached it and waited about 5 more mins and tried to start again and it fired and drove 1 foot till it died again and so i just left it there and will drive it home tomorrow when its a cold engine again.
christian1218 is offline   Reply With Quote
Old 10-14-2009, 09:08 AM   #22
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,692
Thanks: 5
Thanked 121 Times in 120 Posts
Re: S-10 Blazer stalls when engine is hot

When it stalls you need to check for lose of spark or fuel.
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
Old 10-15-2009, 07:09 PM   #23
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

so i dropped the truck off at the repair shop and they are going to run there tests on it tomorrow. When i find out what they find i will post it. They promiced me they would try to duplicate the problems before they do the tests.
christian1218 is offline   Reply With Quote
Old 10-16-2009, 05:02 PM   #24
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

so i got the truck back and they said the ignition control module is shot. sho i bought one and gonna go throw it in real quick and hope thats it!!!
christian1218 is offline   Reply With Quote
Old 10-16-2009, 06:58 PM   #25
christian1218
AF Newbie
Thread starter
 
Join Date: Oct 2009
Location: minot, North Dakota
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

So i just took it for a test drive with the new part "ignition control module" and it works like a champ. Thankyou very much on all the help. I really appriciate it.
christian1218 is offline   Reply With Quote
Old 10-19-2009, 12:23 PM   #26
digimotojohn
AF Newbie
 
Join Date: Oct 2009
Location: Cedar Grove, Wisconsin
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: S-10 Blazer stalls when engine is hot

Hello everyone, I just wanted to let anyone using our Digimoto 5 software that we have a new release that uses new licensing. We will no longer be supporting the old Digimoto 5 licensing so please email us with your name and old serial number so we can send you a new one. Thank you for your time.
digimotojohn is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
s-10, stalls
Go Back   Automotive Forums .com Car Chat > Chevrolet > Blazer > Problem Diagnosis

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:37 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts