Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Pickup | Ram SRT10
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-27-2004, 07:27 PM   #1
gswalker
AF Newbie
 
Join Date: Jun 2004
Location: Cincinnati, Ohio
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
speedometer not working

I have a 2000 dodge ram my check engine light came and speedo quit working. I pulled the codes it was P0500 I replaced the speed sensor in the tranny but it didnt fix it. Help please
gswalker is offline   Reply With Quote
Old 06-27-2004, 09:56 PM   #2
LTJGWorth
AF Regular
 
LTJGWorth's Avatar
 
Join Date: May 2004
Location: Ashland, Kentucky
Posts: 436
Thanks: 0
Thanked 0 Times in 0 Posts
Re: speedometer not working

Electrical? Fuse somewhere? Short? Bad gauge?
LTJGWorth is offline   Reply With Quote
Old 06-27-2004, 10:26 PM   #3
bsmitty
AF Newbie
 
Join Date: Jun 2004
Location: Rockwood, Pennsylvania
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Re: speedometer not working

Their is a speed senor/ abs sensor in the rear diff. toward the top of it. I just had that same trouble. It will probably be a dealer part so go to your local dodge dealer and tell them what you need. I payed $33 to fix it and it all work know and my lights are all off.
bsmitty is offline   Reply With Quote
Old 06-28-2004, 06:12 PM   #4
gswalker
AF Newbie
Thread starter
 
Join Date: Jun 2004
Location: Cincinnati, Ohio
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Re: speedometer not working

Quote:
Originally Posted by bsmitty
Their is a speed senor/ abs sensor in the rear diff. toward the top of it. I just had that same trouble. It will probably be a dealer part so go to your local dodge dealer and tell them what you need. I payed $33 to fix it and it all work know and my lights are all off.
Thanks I found that one I took it out and checked with a meter and it is good I have 5 volts refrence to the sensor I dont have any idea now the chech engine light went off but the speedo still dosent work.
gswalker is offline   Reply With Quote
Old 06-29-2004, 01:33 AM   #5
RexNfx400
AF Regular
 
RexNfx400's Avatar
 
Join Date: Feb 2004
Location: Marysville, Washington
Posts: 331
Thanks: 0
Thanked 2 Times in 2 Posts
Re: speedometer not working

If you don't have a scope to check A/C Freq or pattern. Renew the VSS/RWAL in the rear diff. Hopefully that will be the end of it...
RexNfx400 is offline   Reply With Quote
Old 06-29-2004, 09:50 AM   #6
LTJGWorth
AF Regular
 
LTJGWorth's Avatar
 
Join Date: May 2004
Location: Ashland, Kentucky
Posts: 436
Thanks: 0
Thanked 0 Times in 0 Posts
Re: speedometer not working

There is a guy on another post that said that he had his speed sensor checked and it turned out that his diff was chewed all to hell and had to have it replaced. So this speedo not working could be something worst!
LTJGWorth is offline   Reply With Quote
Old 06-29-2004, 10:43 AM   #7
bsmitty
AF Newbie
 
Join Date: Jun 2004
Location: Rockwood, Pennsylvania
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Re: speedometer not working

I had the right voltage at mine too and the dealer said it could still be bad. So I cahanged it and it worked.
bsmitty is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Pickup | Ram SRT10

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:51 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts