Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mercury > Villager
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-26-2021, 06:48 PM   #1
charles546
AF Newbie
 
Join Date: Mar 2009
Location: pocahontas, Arkansas
Posts: 58
Thanks: 0
Thanked 3 Times in 3 Posts
no power

trying to help neighbor fix his moms villager.he took off alternator to replace but didnt remove battery cable causing a arch when taking wires off alternator. now he has no power to anything but headlights.no fuses are blown dont know where to start looking. please help if you can
charles546 is offline   Reply With Quote
Old 02-27-2021, 01:08 PM   #2
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,575
Thanks: 22
Thanked 171 Times in 167 Posts
Re: no power

I admit I know nothing about this vehicle. But usually when you short something out under the hood, fusible link comes to mind.
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Mercury > Villager

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:01 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts