Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Silhouette
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-12-2019, 07:22 PM   #1
Zacharytm
AF Newbie
 
Join Date: Jan 2019
Location: North Fairfield, Ohio
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
03 silhouette overheating

I have replaced the thermastat & got a new radiator cap. Done a do it yourself flushing system. With still these problems. Just replaced water pump same issue. Over heats & at idle with no heat while hitting gas temp gauge drops & I have heat. Done the 2 bleeders on them and its on & off. Sometimes I have a steady flow other times it spits out alot of air. I have let it run till had a full stream shut it off let it cool down & still nothing.
Zacharytm is offline   Reply With Quote
Old 01-13-2019, 02:39 AM   #2
brcidd
AF Enthusiast
 
brcidd's Avatar
 
Join Date: Jul 2005
Location: troy, Ohio
Posts: 2,217
Thanks: 2
Thanked 145 Times in 143 Posts
Re: 03 silhouette overheating

You need to do a system leak check-- your engine is known for intake manifold leaks and head gasket leaks.....

A cheap do it yourself check is to put a plastic bread bag over the radiator lip- secure with rubber band--- start engine, if bag blows up, you are getting exhaust gases in your cooling system-- means bad heads gasket, or cracked head....
__________________
Automotive A/C Engineer with:
'99 IH 4700 Toy Hauler
(2) '95 GEO Prizms both maroon
'99 GMC Yukon
'95 Chev 3500, 454 Dually Crew Cab- 145k miles-
Wife's Camel trailer puller.
'94 Astro- 370k miles
'94 Firebird Formula- 5.7L 180k miles- gone-
'92 Chevy Lumina Van 3.8L 264k
'86 GMC S-15 - 2.8L 154k
'87 Buick Park Ave . 187k
'86 Buick Park Ave 3.8L 199k miles- gone
'77 Chevy Vega- 2.5L 175k miles gone but not forgotten
'68 Camaro 396 4 spd RS/SS -72k miles-
brcidd is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Silhouette

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:32 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts