Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Alero
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-19-2020, 02:25 AM   #1
juliexlyons
AF Newbie
 
Join Date: Dec 2020
Location: Charleston, West Virginia
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 2004 Oldsmobile Alero slow crank

Shut off my car at the gas station. Wouldn't start back. Thought it was the fuel pump. Cranked over no start and didn't hear the pump kick on. Got it towed home. Replaced the pump the battery was dead when I tried to start it. Jumped it and the headlights seem bright but cranks slow and sluggish and sounds sluggish and airy. White smoke came from inside dash and vents. Starter and alternator are less then a year old. Please help.
juliexlyons is offline   Reply With Quote
Old 12-19-2020, 07:21 AM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,780
Thanks: 18
Thanked 353 Times in 347 Posts
Re: 2004 Oldsmobile Alero slow crank

Welcome to AF, what engine? Also check oil level and condition, any coolant loss?
__________________
maxwedge is offline   Reply With Quote
Old 12-19-2020, 01:11 PM   #3
juliexlyons
AF Newbie
Thread starter
 
Join Date: Dec 2020
Location: Charleston, West Virginia
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2004 Oldsmobile Alero slow crank

2.2 oil is fine. The coolant reservoir is full.
juliexlyons is offline   Reply With Quote
Old 12-19-2020, 03:28 PM   #4
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,598
Thanks: 23
Thanked 173 Times in 169 Posts
Re: 2004 Oldsmobile Alero slow crank

Without voltmeter testing battery/alternator you're just guessing.
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Tags
crank, slow
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Alero

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:01 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts