Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Hyundai > Santa Fe > MY 07+
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-17-2019, 02:38 PM   #1
BillMu
AF Newbie
 
Join Date: Oct 2013
Location: Glen Ellyn, Illinois
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Why is my car pulling after acceleration?

2007 Santa Fe GLS FWD.

Just had the entire front end replaced due to rust (was a Illinois vehicle until we moved to Georgia). Repair facility replaced both front half shafts, tie rod ends, loaded strut assemblies, motor mounts (3) and even did an alignment. Tires are pretty new with plenty of even tread.

Problem: When you accelerate, and then take your foot off of the accelerator, the car jumps to the left or the right. Not enough to put you into another lane, but enough to get your attention to grab the wheel tight. The facility that did the work first tried to fix it by going to OEM half shafts from Hyundai, then they replaced the motor mounts. Neither of these fixed it, and they don't know what to do next. I'm tired of spending money. Ideas?? Thanks.
BillMu is offline   Reply With Quote
Old 03-18-2019, 07:10 AM   #2
CapriRacer
AF Regular
 
Join Date: May 2003
Location: Somewhere in the US
Posts: 300
Thanks: 0
Thanked 8 Times in 8 Posts
Re: Why is my car pulling after acceleration?

I'm wondering if you are experiencing part of the normal torque steer - that when accelerating, the different length half shafts twist - and that tends to steer the car.
CapriRacer is online now   Reply With Quote
Old 03-18-2019, 05:31 PM   #3
BillMu
AF Newbie
Thread starter
 
Join Date: Oct 2013
Location: Glen Ellyn, Illinois
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Why is my car pulling after acceleration?

Quote:
Originally Posted by CapriRacer View Post
I'm wondering if you are experiencing part of the normal torque steer - that when accelerating, the different length half shafts twist - and that tends to steer the car.
I appreciate the response. You may be right, but if you drove it, you would not think this to be normal behavior.
BillMu is offline   Reply With Quote
Old 03-19-2019, 06:27 AM   #4
CapriRacer
AF Regular
 
Join Date: May 2003
Location: Somewhere in the US
Posts: 300
Thanks: 0
Thanked 8 Times in 8 Posts
Re: Why is my car pulling after acceleration?

Quote:
Originally Posted by BillMu View Post
I appreciate the response. You may be right, but if you drove it, you would not think this to be normal behavior.
Except that torque steer IS normal behavior for a FWD, just one that feels really unusual when you first encounter it - and one that is difficult to dial out in the design process.
CapriRacer is online now   Reply With Quote
Old 03-19-2019, 06:44 AM   #5
BillMu
AF Newbie
Thread starter
 
Join Date: Oct 2013
Location: Glen Ellyn, Illinois
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Why is my car pulling after acceleration?

Not disagreeing, but have had the car for 11 years, it never reacted like this before replacing the components. I appreciate your comments!
BillMu is offline   Reply With Quote
Old 03-20-2019, 07:37 AM   #6
CapriRacer
AF Regular
 
Join Date: May 2003
Location: Somewhere in the US
Posts: 300
Thanks: 0
Thanked 8 Times in 8 Posts
Re: Why is my car pulling after acceleration?

Quote:
Originally Posted by BillMu View Post
Not disagreeing, but have had the car for 11 years, it never reacted like this before replacing the components. I appreciate your comments!
OK, I understand now - it was NOT doing it BEFORE.

Look for something loose. Something that might be shifting position when the engine torques.

Do you have a printout of the alignment? If so, look for high levels of caster.
CapriRacer is online now   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
accelerate, pull, swerve, veer
Go Back   Automotive Forums .com Car Chat > Hyundai > Santa Fe > MY 07+

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:14 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts