Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Car Audio
Car Audio Do you live in your car? Then you need to be able to listen to some high-quality music.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 04-14-2004, 12:22 AM   #1
*CuTlAsS*
AF Newbie
 
Join Date: Apr 2004
Location: White Bear Lake, Minnesota
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Killed two batteries and one alternator

I've had a problem with my system. I've got the main power fuse hooked up to the positive on the power cap, then from the positive on the cap running to my power on the amplifier. I have my ground from the chassis to the negative on the power cap. From the negative ground on my amp I have hooked up to another ground. Now I believe this is the proper way with a power cap but I've killed 2 batteries and 1 alternator. Is my system hooked up wrong? Am I missing anything?
*CuTlAsS* is offline   Reply With Quote
Old 04-14-2004, 10:12 AM   #2
bmwm3guy
Banned
 
bmwm3guy's Avatar
 
Join Date: Apr 2004
Location: Gatineau
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to bmwm3guy
Re: Killed two batteries and one alternator

Check to make sure the Lead wire from the main deck is connected right. You might be giving your amp juice all the time even when the car is off.

What kind of car is it?

wait... when you say power cap, do you mean capacitator? because you should not have a ground wire hooked up to the capacitator. Just the Power wire. The ground ONLY goes from the amp to your chassis. This might be why....
bmwm3guy is offline   Reply With Quote
Old 04-14-2004, 12:14 PM   #3
sr20de4evr
AF Enthusiast
 
sr20de4evr's Avatar
 
Join Date: Jul 2002
Location: San Antonio, TX, Texas
Posts: 3,100
Thanks: 0
Thanked 2 Times in 2 Posts
Re: Killed two batteries and one alternator

Yes you should have a ground wire hooked up to the capacitor, it sounds like you have it wired right. How much power are the amps drawing, what's your gain set at, and what size is your alternator? A cap is a bandaid, it will NOT help if you have a mortal wound (read: it won't do a damn thing if your amps are drawing way more current than your alternator can provide)
__________________
'01 Black Sentra SE
Weapon-R intake, HS header, HKS catback, ES motor mounts, B&M short shifter, Tein coilovers
Alpine 9835, Adire Koda 6.1, Adire Brahma 15, Arc 2100cxl, Linear Power 2.2hv, Cadence ZRS-8

'05 Silver WRX STi
Injen SES Downpipe, HKS Carbon-Ti catback, Cobb Stage 2 Tune, TiC Super Shifter, TiC Klunk Killer, Tein springs, Nitto NT555R Drag Radials
sr20de4evr is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Car Audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:41 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts