Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Envoy
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-03-2014, 12:01 PM   #1
marcvad
AF Newbie
 
Join Date: Oct 2005
Location: manchester, New Hampshire
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2005 Envoy Onstar / Electrical Problem

I have a 2005 Envoy with OnStar (BTW I don't pay to use the service so I gues it is "idle"). For the past year or so whenever there is just the right amount of moisture in the air (i.e. a warm day that cools off in evening, or in winter when the car is dry and cold but then warms up) all of my dash lights turn on (but the motor still runs fine). Also the radio shuts off and I lose all control over windows. The A/C also stops working (even though the AC light will remain on). Sometimes after a few minutes the problem will go away and everything will reset if I hit the rightmost button on the rearview mirror - I then get the generic Onstar voice saying "The OnStar system is not active". But even when everything comes back on I get what looks like a light shaped like a lock on the dash that stays on.

Someone told me (and this makes some kind of sense) that it has to do with the OnStar system because everything that is connected with it seems to malfunction.

Note I DO have an aftermarket radio installed, however I did use the $100+ harness that "fools" the car into thinking the stock radio is in there. Also this problem started BEFORE the aftermarket radio was put in but I thought I'd mention it anyway.

I have tried disconnecting the OnStar unit located under the rear passenger seat but the problem still remains. I am guessing that somewhere there is a solder joint or some other set of wires/components that are just a fraction of a millimeter apart and any moisture in the air is causing a short. I just don't know where else to look besides the OnStar unit itself.

Any ideas?
marcvad is offline   Reply With Quote
Old 09-19-2015, 12:54 PM   #2
Tux05
AF Newbie
 
Join Date: Aug 2015
Location: Sudbury
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2005 Envoy Onstar / Electrical Problem

I have a 05 Envoy also have a OnStar problem. Not the same as your problem but mine keeps on saying phone not available. Looked in the OnStar manual and called OnStar but all they said was take it to the dealership. Can you tell me where the OnStar is located under the rear seat.Wish I could help with your problem but hell I can't even turn my onstar off Tux05
Tux05 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > GMC > Envoy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:43 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts