Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Envoy
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-26-2016, 12:15 PM   #1
stan_5150
AF Newbie
 
Join Date: Jun 2004
Location: Rosemount, Minnesota
Posts: 65
Thanks: 4
Thanked 0 Times in 0 Posts
Mystery 10.9 bolt

2006 Envoy SLT (178K).

I found a loose 10.9 bolt laying on the lines between the cooling fan and the engine block. I accomplished a visual check near the front of the engine compartment but I can't see anything apparent. I've looked online and I've looked at the water pump area but everything there seems in order.

I was driving last night and noticed a noise when making right hand turns. I checked for debris but didn't find anything, and upon inspection of the engine compartment I ran across this bolt.

If anyone has any ideas where I should look it would be greatly appreciated. Thanks.
stan_5150 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
10.9, bolt
Go Back   Automotive Forums .com Car Chat > GMC > Envoy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:13 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts