Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Envoy
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-10-2011, 06:40 PM   #1
smitty782
AF Newbie
 
Join Date: Feb 2011
Location: Sheffield Lake, Ohio
Posts: 24
Thanks: 3
Thanked 0 Times in 0 Posts
code 128

Im spending to much time on this site!!!!!!! !Anyway, My 05 Envoy with a 4.2 L is throwing a code 128 temp below thermostat temp what do I do to solve this problem HELP PLEASE
smitty782 is offline   Reply With Quote
Old 02-10-2011, 08:00 PM   #2
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 102 Times in 95 Posts
Re: code 128

Check coolant level, then check the thermostat outlet housing with an infra red thermometer after driving for 20 minutes or so. Should be 195 degrees. If not, the thermostat needs to be replaced.
__________________
You have to know how it works,
to figure out why it doesn't.
old_master is offline   Reply With Quote
Old 02-11-2011, 08:12 AM   #3
smitty782
AF Newbie
Thread starter
 
Join Date: Feb 2011
Location: Sheffield Lake, Ohio
Posts: 24
Thanks: 3
Thanked 0 Times in 0 Posts
Re: code 128

Thanks for the info is the thermostat on the 4.2L on the upper hose on the passenger side or on the lower hose on the drivers side
smitty782 is offline   Reply With Quote
Old 02-11-2011, 07:03 PM   #4
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 102 Times in 95 Posts
Re: code 128

Driver side of engine, behind the alternator.
__________________
You have to know how it works,
to figure out why it doesn't.
old_master is offline   Reply With Quote
Old 02-12-2011, 03:19 PM   #5
smitty782
AF Newbie
Thread starter
 
Join Date: Feb 2011
Location: Sheffield Lake, Ohio
Posts: 24
Thanks: 3
Thanked 0 Times in 0 Posts
Re: code 128

Thanks found it and replaced it and also found my noise. the guy I bought it from sprayed the belt and pullys with either lithium grease or belt dressing to find out what was making the noise and I checked all the pullys and it turned out to be the belt after pulling the tension pully off several times I finally went and got a new belt...Live and learn anyway thanks for your help
smitty782 is offline   Reply With Quote
Old 02-12-2011, 06:46 PM   #6
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 102 Times in 95 Posts
Re: code 128

The only "fix" for a noisy serpentine belt is make sure the pulleys are lined up perfectly with each other and replace the belt. Did your P0128 go away?
__________________
You have to know how it works,
to figure out why it doesn't.
old_master is offline   Reply With Quote
The Following User Says Thank You to old_master For This Useful Post:
smitty782 (02-15-2011)
Old 02-15-2011, 01:13 PM   #7
smitty782
AF Newbie
Thread starter
 
Join Date: Feb 2011
Location: Sheffield Lake, Ohio
Posts: 24
Thanks: 3
Thanked 0 Times in 0 Posts
Re: code 128

Yes code went away after i replaced the thermostat cleaned all pulleys and replaced belt and the noise went away All good for now thanks for your help..Ken
smitty782 is offline   Reply With Quote
Old 07-16-2014, 09:52 PM   #8
hongdida
AF Newbie
 
Join Date: Jul 2014
Location: orange, California
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: code 128

"Im spending to much time on this site!!!!!!! !Anyway, My 05 Envoy with a 4.2 L is throwing a code 128 temp below thermostat temp what do I do to solve this problem HELP PLEASE"


Same issue here!!! Why?
hongdida is offline   Reply With Quote
Old 07-16-2014, 09:54 PM   #9
old_master
Advisor/Moderator
 
old_master's Avatar
 
Join Date: Nov 2005
Location: Belleville, Michigan
Posts: 5,183
Thanks: 6
Thanked 102 Times in 95 Posts
Re: code 128

See post #2 above.
__________________
You have to know how it works,
to figure out why it doesn't.
old_master is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble codes danielgast46 F Series 6 04-06-2009 07:06 AM
1993 Acura integra Stereo Code Omega-Factor Interior | Audio | Security 1 03-25-2009 07:08 PM
01 Sport Trac Door Code??? levi.calhoun Explorer | Explorer Sport Trac 1 03-23-2009 10:09 PM
2001 malibu code 128 r.rogers8 Malibu 3 01-02-2008 02:57 PM
"Check Engine Soon" Code 128 meaning canesrulealways Jimmy 3 12-31-2005 06:27 AM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > GMC > Envoy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:34 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts