Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Eagle > General Discussion
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-11-2003, 12:04 PM   #1
honeecone
AF Newbie
 
Join Date: Nov 2003
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy 1992 eagle talon help

i have a 1992 eagle talon non turbo 2.0l i just had a computer module and a oxygen senor put in ,and now my car is still not running right someone told me it has to do with a coil but what coil and how do i know for sure that's it .when i start the car it is fine untill i get moving the engine light comes on when i lose power and then it bogs out on me and the car won't go so i put the car in netural and rev up the engine while im moving and the engine light goes out then i have power again to get going ,but does this all the time i have to keep doing this every time i go somewhere. can someone please help me
honeecone is offline   Reply With Quote
Old 11-14-2003, 03:14 AM   #2
boots03
AF Enthusiast
 
Join Date: Aug 2003
Location: ankeny, Iowa
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to boots03 Send a message via Yahoo to boots03
Re: 1992 eagle talon help

you wont know if its the coil, but its one of thoes things that you should at least see if it might fix it, my 92 talon used to cut out and run on 2-3 cylinders every so often untill i changed them. since i havnt driven your car, i wont kow, but this is my input.
boots03 is offline   Reply With Quote
Old 11-14-2003, 11:41 AM   #3
honeecone
AF Newbie
Thread starter
 
Join Date: Nov 2003
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1992 eagle talon help

thanks, im thinking the same thing , i took it and had a diagnstic check it says has something to do with code 44 ignition signal so they erased it out and told me if it does the same thing to bring it back and will see if the same code comes up but if it isnt the same code then there is something else wrong ,so it happen the engine light came back on and bogs so have anther appointment again on monday
honeecone is offline   Reply With Quote
Old 11-22-2003, 02:54 PM   #4
PROJEKT_TALON
AF Newbie
 
Join Date: Nov 2003
Location: Tecumseh, Oklahoma
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1992 eagle talon help

From what you saying your car is doing, it's the same thing my car is doing, and the problem with my car is the Ignition Power Transistor is going bad. I can be driving down the road just fine, then all of a sudden that check engine light comes on and the performance just goes to nothing. Sometimes when it does it, I can push in on the clutch and coast, and it will start running normal again for a while, but sometimes I have to stop and kill the engine and start it back up. So I think it could be the Ignition Power Transistor. Hope this is helpful. Good Luck
PROJEKT_TALON is offline   Reply With Quote
Old 12-26-2003, 08:26 PM   #5
honeecone
AF Newbie
Thread starter
 
Join Date: Nov 2003
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Re: 1992 eagle talon help

Quote:
Originally Posted by PROJEKT_TALON
From what you saying your car is doing, it's the same thing my car is doing, and the problem with my car is the Ignition Power Transistor is going bad. I can be driving down the road just fine, then all of a sudden that check engine light comes on and the performance just goes to nothing. Sometimes when it does it, I can push in on the clutch and coast, and it will start running normal again for a while, but sometimes I have to stop and kill the engine and start it back up. So I think it could be the Ignition Power Transistor. Hope this is helpful. Good Luck
my car is mannal i thought that the car wouldnt start at all if the ignition power transistor was bad but i did change one of the ignition coil and it still bogs out and no power but when i let my car run for say 45 min. to an hour before pulling out it runs fine but to just start it up and go i have the engine light come on and no power to go have to put it in nuteral and rev it out to get power the whole time i an driving my car it does this it is drving me crazy so far i have about 1000 in it running out of money anything that you can think of that i need to do to my car
honeecone is offline   Reply With Quote
Old 10-27-2005, 07:01 PM   #6
Alan S.
AF Newbie
 
Join Date: Oct 2005
Location: Memphis, Tennessee
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1992 eagle talon help

might be the fuel filter,or pump...have you checked the fuel rail pressure????idling requires less fuel,and pressure,anything above idle requires more fuel and subsequent pressure.....
Alan S. is offline   Reply With Quote
Old 10-29-2005, 09:50 AM   #7
UncaringMrBC
AF Newbie
 
Join Date: Oct 2005
Location: Mtn. Grove, Missouri
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
id say to change the fuel filter next...its cheap and it made mine do that once too...i think mines going to eventually be the fuel pump but a filter fixed it for a while
UncaringMrBC is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Eagle > General Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:37 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts