Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Engineering/Technical
Engineering/Technical Ask technical questions about cars. Do you know how a car engine works?
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-02-2003, 09:43 AM   #16
Ricochet
Banned
 
Ricochet's Avatar
 
Join Date: Jun 2003
Location: Columbus, Ohio
Posts: 5,591
Thanks: 0
Thanked 1 Time in 1 Post
Re: rotten egg smell

Quote:
Originally Posted by 88_SC_CRX_Si
Have you pulled the plugs and checked their color...?
Do this. If the engine is running lean your plugs will have white spots on them from the heat, and your catalytic converter is the reason for the smell. If this is the problem, I'm not too sure how to make it run richer except make sure your fuel injectors are clean... The extreme heat in your combustion chambers will wear the engine faster, so the sooner you get it fixed the better.
Ricochet is offline   Reply With Quote
Old 10-02-2003, 09:43 AM   #17
88_SC_CRX_Si
AF Enthusiast
 
Join Date: Aug 2002
Posts: 159
Thanks: 0
Thanked 0 Times in 0 Posts
One more thing... Honda's are set-up to run really lean at idle. Those of you that have A/F ratio gauges can see that anytime when doing so. Here again that depends on the condition of the O2 sensor... hehehe

Since yours is a v6, might check into how the idle is handled...
__________________
88' CRX Si - JRSC @ 6psi Z6 Mini-Me, JDM SiR Conversion
NOS #5122, JR Liquid InterCooling System
ZYDNE SECU, 450's
B&M FP Set, B&M Command Flo
AutoMeter - Phantom FP, A/F, N2O, Boost gauges & pods,
ARP HSKit, AEM Pads, 87' HF Drums, DYI CAI
88_SC_CRX_Si is offline   Reply With Quote
Old 10-03-2003, 08:22 AM   #18
88_SC_CRX_Si
AF Enthusiast
 
Join Date: Aug 2002
Posts: 159
Thanks: 0
Thanked 0 Times in 0 Posts
Might try taking it to someplace that has a scan tool, the CEL/MIL's are more detailed now, then the eariler version OBD. Sooo that should be able to tell you which sensor(s) are acting up. By either sending to much voltage or not enough to the ECU.

With todays systems it's practically impossible to guess what is wrong without the proper tools to troubleshoot. Like mentioned above about the scan tool, along with a voltmeter, oscilloscope. Without those it's just to hard/$$$$$ to try and and figure out. When something is on the "verge" of failure. Otherwise it just turns into a waiting game, until it finally fails all the way and sends the needed MIL.
__________________
88' CRX Si - JRSC @ 6psi Z6 Mini-Me, JDM SiR Conversion
NOS #5122, JR Liquid InterCooling System
ZYDNE SECU, 450's
B&M FP Set, B&M Command Flo
AutoMeter - Phantom FP, A/F, N2O, Boost gauges & pods,
ARP HSKit, AEM Pads, 87' HF Drums, DYI CAI
88_SC_CRX_Si is offline   Reply With Quote
Old 11-02-2003, 12:41 PM   #19
Rob826947
AF Newbie
 
Join Date: Nov 2003
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up rotten Egg Smell

People in here are all telling you the wrong thing. Your problem is your battery that is emitting sulferic acid from its vents that is why you smell the rotten egg smell that is what sulferic acid smells like, the reason your car is harder to start is because its not fully charged and you probably need a new battery and the fact that you did a tune up on your car has nothing to do with it most likely all it is coincidence. so test your battery and you will see it is probably not up to specs but also make sure that you have not crossed any wiring like from the alternator or anything else that could be causing the battery to heat up.


Thanks!
Rob826947 is offline   Reply With Quote
Old 11-02-2003, 12:43 PM   #20
Rob826947
AF Newbie
 
Join Date: Nov 2003
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: rotten egg smell

Quote:
Originally Posted by snipez
hi
i have new wires, new plugs, new alternator


would a smell of rotten eggs be coil related?



the car takes a second longer to start when cold

check your battery what you smell is sulferic acid emmiting from the battery and make sure you have not crossed any wires that might be causing the batt to overheat. as for the starting problem replace the battery
Rob826947 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
car dead rotten egg smell, strange noise yall Intrigue 11 04-28-2010 07:11 PM
rotten egg smell sunfirechick General Discussions 16 11-27-2004 03:27 AM
Auto tranny Q's; rotten egg smell 86FieroGT Engineering/Technical 3 05-10-2004 12:41 AM
Rotten egg smell......... daddymart001 Grand AM 1 12-04-2003 08:09 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Engineering/Technical

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:17 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts