Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mercury > Cougar
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-28-2012, 08:07 PM   #1
DragonLord3688
AF Newbie
 
Join Date: Nov 2007
Location: Staunton, Virginia
Posts: 47
Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation Suspension probs, need HELP before accident!

Okay, so my shift linkage in my car has been really crappy, loose, and have had problems with the shifter and having to slam it in to gear otherwise letting off the clutch "pops" the shifter out of gear almost always in 1st and 3rd. Even in gear there is almost as much wiggle room to each gear as if I was in neutral, especially when I hit 3rd, 4th, 5th, and Reverse...

Now when I take (primarily left) turns the vehicle bucks and you feel like a clunky popping in the car almost like when the clutch pops the gear out, my car stays in gear, I've been noticing BAD vibration over 60 mph but Merchant tire said it was because of defects in my tires some sort of "bumps" near the outer tread...

Now I was trying to find new shift linkage the other day because whatever keeps the cable on the gearbox broke off when I got the vehicle and I took a bushing out of the Help! section at AutoZone to put on there, its very loose but is keeping the cable from falling off that little metal stud...

Now I need to know is this actually a CV axle problem or something in the gearbox/transmission/linkage?

Thanks!
Sean
DragonLord3688 is offline   Reply With Quote
Old 10-02-2012, 12:06 PM   #2
DragonLord3688
AF Newbie
Thread starter
 
Join Date: Nov 2007
Location: Staunton, Virginia
Posts: 47
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Suspension probs, need HELP before accident!

Well guys it turns out it was the transmission after all.. managed to get it to a shop, they test drove it and something finally snapped and the car stopped moving at all, once the clutch hit the "catch" it would make a god awful grinding.... time for a new transmission...

Fortunately I found one with shipping for $350.00 guaranteed for 6 months and tested... only problem it has 180k miles, my car has 120k... would it be worth it?
DragonLord3688 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Tags
accident, axle, safety, suspension
Go Back   Automotive Forums .com Car Chat > Mercury > Cougar

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:53 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts