Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Toyota > 4Runner/GX470
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-03-2016, 09:46 AM   #1
Brandonhouda
AF Newbie
 
Join Date: Nov 2016
Location: Bremerton, Washington
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
please help 95 4runner lost all power

please help! Went out yesterday and started my truck to warm it up and turned on running lights, came out 5 min later and passenger side front and back running lights were off. originally thought fuses but checked all and all were good. today went out to start truck and when i turned the key and click.... all power was gone!! thought I left a light on and battery died. but tested battery and all is good and not dead! was able to jump truck from wifes car but after letting it run and drove a little bit, turned it off and when i tried to turn it back on same thing! i noticed when driving that the stereo turned off and on a couple times acting like it was loosing power. not sure if these two things have anything to so with each other but seems like they might! I have read a couple other forums and saw that some were saying check the cable coming off the positive terminal into the fuse box? any suggestions would be great! I love my truck and want it back! please help!
Brandonhouda is offline   Reply With Quote
Old 11-03-2016, 09:56 AM   #2
Crvett69
AF Moderator
 
Crvett69's Avatar
 
Join Date: Oct 2004
Location: Bellingham, Washington
Posts: 1,738
Thanks: 0
Thanked 73 Times in 73 Posts
Re: please help 95 4runner lost all power

make sure your battery connections are good and clean and tight. also if you have a voltmeter check battery voltage while running, should have around 13.5-14 volts at idle. your alternator might be worn out. if you dont have a voltmeter you can take car or alternator down to your local parts store. most will check battery and alternator for free
Crvett69 is offline   Reply With Quote
Old 11-04-2016, 10:10 PM   #3
Brian R.
Resident Chemist
 
Brian R.'s Avatar
 
Join Date: Feb 2004
Location: Rockville, Maryland
Posts: 8,557
Thanks: 105
Thanked 149 Times in 149 Posts
Send a message via Yahoo to Brian R.
Re: please help 95 4runner lost all power

Please don't post in more than one thread....
Read the other thread too.
__________________
Forum Guidelines:http://www.automotiveforums.com/vbulletin/guidelines.html

"What we've got here is a failure to communicate"
Brian R. is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
1995, 4runnner
Go Back   Automotive Forums .com Car Chat > Toyota > 4Runner/GX470

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:27 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts