Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Impala | Impala SS
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-06-2018, 08:30 PM   #1
gigi8
AF Newbie
 
Join Date: May 2014
Location: Chardon, Ohio
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
2006 Chevy Impala SS 5.3L

If anyone could please help I would be forever grateful. The battery light is staying illuminated - the car will start and run but the warning light comes on and says check the charging system. It has a new alternator and battery but the battery light still stays illuminated. We have checked the wiring and could not find any problems. Could it be a PCM?? Would the best thing to do is take it to a dealer. Any suggestions very much appreciated!!
gigi8 is offline   Reply With Quote
Old 11-07-2018, 07:12 AM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,536
Thanks: 13
Thanked 320 Times in 314 Posts
Re: 2006 Chevy Impala SS 5.3L

Ok, so is the charging system actually charging? Been checked with a volt meter?
__________________

Last edited by maxwedge; 11-07-2018 at 07:55 AM.
maxwedge is offline   Reply With Quote
Old 11-07-2018, 09:20 AM   #3
gigi8
AF Newbie
Thread starter
 
Join Date: May 2014
Location: Chardon, Ohio
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Re: 2006 Chevy Impala SS 5.3L

Hi - yes the charging system has been checked with a volt meter.
gigi8 is offline   Reply With Quote
Old 11-07-2018, 09:21 AM   #4
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,536
Thanks: 13
Thanked 320 Times in 314 Posts
Re: 2006 Chevy Impala SS 5.3L

Ok, you need to have the bcm and pcm scanned to see why the lite is still on.
__________________
maxwedge is offline   Reply With Quote
Old 11-07-2018, 09:26 AM   #5
gigi8
AF Newbie
Thread starter
 
Join Date: May 2014
Location: Chardon, Ohio
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Re: 2006 Chevy Impala SS 5.3L

Okay-thank you - was definitely leaning towards that but open to the possibilities of checking something else.
gigi8 is offline   Reply With Quote
Old 11-07-2018, 10:38 PM   #6
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 4,993
Thanks: 62
Thanked 614 Times in 606 Posts
Re: 2006 Chevy Impala SS 5.3L

Does the battery have an extra wire going to a sheathing around the battery cables? If yes, it's a current sensor.... It's almost like an inductive pickup....this signal goes to the BCM...
Check for codes like Max suggested...especially "B" codes....
Tech II is offline   Reply With Quote
Old 12-11-2018, 08:03 AM   #7
j cAT
AF Fanatic
 
Join Date: Oct 2007
Location: EVERETT, Massachusetts
Posts: 10,823
Thanks: 5
Thanked 431 Times in 430 Posts
Re: 2006 Chevy Impala SS 5.3L

Quote:
Originally Posted by gigi8 View Post
Okay-thank you - was definitely leaning towards that but open to the possibilities of checking something else.
the alternator connections maybe the problem . also post the voltage you have measured.. 13.75-14.75VDC .. the small wire connector on the alternator sure can be a problem... I would also bring back the new ??? alternator or is this a refurbished alternator ???? .. if this new alternator is refurbished and cleaned up so it looks new then these IMO would never buy..

also my guessing is you are not the person doing this diagnostic ..if you did you would post the specific tests voltages etc..
there is a TSB on this vehicle about BCM re-programing but it may help but the light / dic may indicate this again..

these new IMPALA SS vehicles are not to my liking .. too small and not good handling with the foot on the gas.. I own a 96 Impala since day one still running great no major repairs .. I did have to replace 4 water pumps.. LOL..
j cAT is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Impala | Impala SS

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:52 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts