Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Eclipse/Talon/Laser > Off-Topic
Off-Topic Talk about anything other than cars.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-29-2004, 09:28 AM   #1
FletchTrick
AF Newbie
 
Join Date: Mar 2004
Location: Vancouver, Washington
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
turns over but won't start...help!

While driving, (1990 eclipse 1.8) the car started jerking like it was running out of gas. It died and I heard a loud series of clicks. It turned out to be the ECM. Bought one from a junkyard and put it in there. The fuel pump won't come on when the key is on. It did come on when someone was under the car and pulled the fuel punp electrical connector out of it's bracket. There is spark but no gas getting to the spark plugs. Fuses, fusible link are all fine. I am wondering if the ECM was no good in the first place. Any clues? Much appreciation, FletchTrick
FletchTrick is offline   Reply With Quote
Old 03-31-2004, 10:09 PM   #2
FletchTrick
AF Newbie
Thread starter
 
Join Date: Mar 2004
Location: Vancouver, Washington
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
O.K. now I have taken the cover off of the fuel pump relay and it looks fine in there. Put the relay back in. Thought I would double check the connector again and because the plastic tab on the housing of the relay had snapped off, the housing was loose. When I pulled the wire harness to disconnest, the motor started turning over without the key in the ignition. Could this be a short somewhere in that wiring harness that comes from the relay or??? Please input. Need Help. Five weeks, no car.
FletchTrick is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mitsubishi > Eclipse/Talon/Laser > Off-Topic

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:14 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts