Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Cars in General
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-07-2018, 06:57 PM   #1
aGoodOldRub
AF Newbie
 
Join Date: Sep 2018
Location: Oceanside
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Control arm moves when trying to remove tire lug nuts

So recently I was having creaking on my rear driver side t tire so probably one of the bushing and to check it I tried to take the wheel off but when I give some power to remove one of the lug nuts whole hub assembly moves alot I checked what parts was moving it looks like lower control arm and toe link just moves upward with the power you apply to loosen tire lug nuts and I assume it is not normal since it wasnt like that before ( I guess) and since it started making creaking from that tire when going over bumps and literally just accelerating and making turns. Do you guys think it is the lower control arm failing ? Or toe link or both and how can I diagnose it to know which part is faulty. Thank you for anyone who tries to help.
aGoodOldRub is offline   Reply With Quote
Old 10-07-2018, 07:20 PM   #2
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 5,430
Thanks: 5
Thanked 136 Times in 133 Posts
Re: Control arm moves when trying to remove tire lug nuts

The control arm moves with the suspension. Your creak could be a bushing though.
__________________
Stealthee is offline   Reply With Quote
Old 10-08-2018, 03:22 PM   #3
carbuilder2002
AF Enthusiast
 
Join Date: May 2006
Location: Durham
Posts: 1,209
Thanks: 0
Thanked 31 Times in 29 Posts
Send a message via MSN to carbuilder2002
Re: Control arm moves when trying to remove tire lug nuts

Certainly sounds like badly worn or failed suspension bushes
carbuilder2002 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Cars in General

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:54 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts