Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Volvo > Cross Country/XC70/XC90
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-02-2008, 03:16 PM   #1
bradnight
AF Newbie
 
Join Date: Sep 2008
Location: san francisco, California
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
bizarre power and engine failure 2004 XC90

On a 6 hour drive to Los Angeles, my 69,000 miles, 2004 Volvo XC 90 experienced a severe "thump" in the front end, which was then followed by a very brief (split second) internal (meaning dashboard lights, hi-fi, dome lights, etc) power failure. Initially, the power failure would last only a split second and then car would continue running as normal, and there we no error codes or check engine lights. This happened as many as five times in a 6 hour drive.

But on the last long drive home, the "thump" was harder than usual, and the lights internally completely went out, hazard lights could not be turned on, blinkers could not be switched on, hi-fi went out, etc (though the electric windows would work).

I pulled over, and turned the car off and restarted it, and the yellow exclamation point dashboard icon/alert lit up, and a service message flashed referring to the anti-lock brake failure, and that the SRS needed to be checked.

I have it at another dealership in Northern California, who seems equally mystified and have told me that they dont think the error code of check the SRS is going to fix the problem.

Any advice you can offer would be appreciated. Thx, Brad
bradnight is offline   Reply With Quote
Old 11-27-2008, 09:27 PM   #2
sjrior
AF Newbie
 
Join Date: Nov 2008
Location: Mahopac, New York
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: bizarre power and engine failure 2004 XC90

Were you able to find the problem? Having the same issue and getting the run around at Volvo.
sjrior is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Volvo > Cross Country/XC70/XC90

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:51 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts