Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Volvo > Cross Country/XC70/XC90
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-18-2010, 10:56 AM   #1
wigglewerks
AF Newbie
 
Join Date: Dec 2008
Location: Jordan, Minnesota
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
No Start

04 XC90 T6. just replaced the turbos and now will not start. I found the there is no injector pulse. I have full fuel pressure and all spark plugs are firing. Scaned the vehicle and found fault U0002 high speed CAN communication BUS performance. the only info i can find is that is Control module internal fault. Faulty signal. permanent fault.

Dose this mean that my ecm is not providing the injector signal because its faulty?
Any help would be great Thank
Tim
wigglewerks is offline   Reply With Quote
Old 11-02-2010, 01:54 PM   #2
wigglewerks
AF Newbie
Thread starter
 
Join Date: Dec 2008
Location: Jordan, Minnesota
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Re: No Start

Well I know its been awhile and didn't get any help from anyone on here, due to it being such a weird problem. Figured i would post the results. found the CEM was taking out the CAN bus. not sure why it started after i had the turbo out. but anyway. replaced with a junk yard module and it fired right up. After doing a search for CEM's on google i found a few post, q/a about how they can be a common problem. Anyway hope this helps anyone out in the future. Thanks
wigglewerks is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Volvo > Cross Country/XC70/XC90

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:00 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts