Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Lumina
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 08-14-2018, 01:27 PM   #1
blk95lumina
AF Regular
 
Join Date: Oct 2008
Location: Houston, Texas
Posts: 101
Thanks: 1
Thanked 0 Times in 0 Posts
Bolt Specs & Thread Size for Front Hub and Speed Sensor

Hello,
Need to replace the front hub and front wheel speed sensor bolts on a 95 Lumina LS 3.1L w/ ABS.

Everything is rusted to the point at which a torch will be required.

Anyone know the specs for these bolts?

Thanks.
__________________
1995 Lumina LS Sedan 3.1L - 212K mi - Daily Driver
2002 Accord EX Sedan V-6 - 206K mi - Wife's Daily Driver
2000 Silverado LS RCSB 5.3L - 165K mi
blk95lumina is offline   Reply With Quote
Old 08-14-2018, 10:43 PM   #2
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: Bolt Specs & Thread Size for Front Hub and Speed Sensor

There are no speed sensor bolts....the sensor is part of the hub.

Just an axle nut, and 3-13mm bolts on the inside......these usually come with the new hub......

If specs are not in instructions in box, a place like Autozone can get you the specs online, especially if you buy it from them....or sign up with them, it's free, and you can look up the specs yourself....
Tech II is offline   Reply With Quote
Old 10-23-2019, 09:44 PM   #3
blk95lumina
AF Regular
Thread starter
 
Join Date: Oct 2008
Location: Houston, Texas
Posts: 101
Thanks: 1
Thanked 0 Times in 0 Posts
Re: Bolt Specs & Thread Size for Front Hub and Speed Sensor

Turns out I got everything apart without a torch, kept the same old hubs and bolts and been over a year now and everything is still going good. Still the original hubs. Had to take it all apart to replace the front axle seals. And the speed sensor actually did have a bolt and 2 alignment pins. That one bolt on the speed sensor took more time than any other b/c it was smaller and rusted the most. Still running the original CV axles too. Not a single tear in any of the boots.
__________________
1995 Lumina LS Sedan 3.1L - 212K mi - Daily Driver
2002 Accord EX Sedan V-6 - 206K mi - Wife's Daily Driver
2000 Silverado LS RCSB 5.3L - 165K mi
blk95lumina is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Lumina

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:41 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts