Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > ZX2
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-17-2009, 10:36 AM   #1
ddppci
AF Newbie
 
Join Date: Feb 2009
Location: Columbus, Ohio
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
1998 Zx2 Cruise Control Problems

I have a standard 1998 ZX2. When traveling on the highway at about 60mph...... after turning on the cruise control then pushing the set button to a certain speed (say 60 mph) my vehicle will go up to about 70 without me pushing on the accelerator. I try to turn off the cruise control but will not turn off. If you put the car in neutral it just rev's up high. Turning the engine off quickly and back on while driving didnt do anything. After stopping, turning the engine off moving the control cable to the engine back and forth (which seemed to be in proper locations). I start the vehicle back up and then the cruise is off. Does anyone know what this sounds like? This has happened the last 3 times I tryed to use the cruise.

Thanks,
ddppci
ddppci is offline   Reply With Quote
Old 02-17-2009, 11:59 AM   #2
Davescort97
Escort guy
 
Join Date: Dec 2004
Location: Garfield, Arkansas
Posts: 2,486
Thanks: 0
Thanked 3 Times in 3 Posts
Re: 1998 Zx2 Cruise Control Problems

Welcome to AF! Do you have an automatic or manual? Does the cruise go off if you hit the brakes? If a manual does the cruise go off if you depress the clutch?
The deactivator switch could be bad about shutting the system down. A loose or binding speed control actuator cable between speed control actuator and throttle body could cause the symptoms you are talking about. A binding cable will cause all the problems you have. It is easy enough to replace or lubricate with WD 40. A new cable would be the right way to go.
Davescort97 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
ford zx2 cruise control
Go Back   Automotive Forums .com Car Chat > Ford > ZX2

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:34 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts