Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Malibu
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-14-2007, 01:06 PM   #16
dan yost
AF Newbie
 
Join Date: Oct 2007
Location: Perris, California
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

The problem I found with my left front turn signal after 10K miles, was that the contacts in the connector were not touching the bulb any longer. A quick bend with a small screwdriver and I've been back in business. Nothing burned out, no electrical shorts, no bad fuses, no corrosion.
Of course, I took the lamp assembly out of the vehicle before I stuck the screwdriver in there...
dan yost is offline   Reply With Quote
Old 10-14-2007, 05:46 PM   #17
stratford_boy
AF Newbie
 
Join Date: Mar 2006
Location: stratford
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

Usually any issues with wildly flashing signals will be either: a burnt bulb or a connection issue at the bulb...try replaceing the bulb, locating by using hazards, if replaceing the bulb still does not repair your issue, look at the connection at the bulb...
stratford_boy is offline   Reply With Quote
Old 12-04-2007, 09:10 PM   #18
Hark
AF Newbie
Thread starter
 
Join Date: Jan 2006
Location: L, Illinois
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

Okay - this problem is still not fixed - daughter & boyfriend haven't taken care of the problem where they are - not sure how I'm supposed to help when she's 4 hours away - but she says it constant now. When she was home last, the wiring was checked (quickly due to time constraints) and the connectors for the bulbs - and the rear bulbs were also changed. When she's home for Christmas I'm about ready to replace every part it could possibly be. On a Grand Prix forum I read where this symptom (wildly flashing turn signals) was a problem caused by the turn signal switch/stalk itself - does anyone know if this could possibly be? I've called the dealerships - no one seems willing to fess up to a relay or anything else other than a wiring problem. Is there a relay for the goofy things - or could it be the switch?
Hark is offline   Reply With Quote
Old 12-05-2007, 04:54 PM   #19
wpbharry
AF Regular
 
Join Date: Feb 2004
Location: Charlotte, North Carolina
Posts: 399
Thanks: 0
Thanked 1 Time in 1 Post
Re: 04 Malibu turn signal problem

There's new info (w/i the last 10 days) in an Edmund's forum that this is caused by too much voltage being sent to the turn signals - one person has this problem recurring as well. He (or she) had the problem fixed by the Chevy dealer. They knew immediately how to fix it. I don't think the exact fix was detailed.
wpbharry is offline   Reply With Quote
Old 01-19-2008, 09:33 PM   #20
nick8519
AF Newbie
 
Join Date: Jan 2008
Location: Michigan City, Indiana
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

My buddy's wife drives a 2000 or 2001 malibu and had a problem with the turn signals blinking rapidly or not blinking at all. After lots of attempts to fix, the replacement of the hazard switch fixed her problem. Just thought I'd let you know...Good Luck!! opcorn:
nick8519 is offline   Reply With Quote
Old 01-20-2008, 07:29 AM   #21
wpbharry
AF Regular
 
Join Date: Feb 2004
Location: Charlotte, North Carolina
Posts: 399
Thanks: 0
Thanked 1 Time in 1 Post
Re: 04 Malibu turn signal problem

That was a common problem with the '97-'03 generation, but it's not a problem with the '04-'07s.
wpbharry is offline   Reply With Quote
Old 02-13-2010, 08:02 PM   #22
jdapthorp@kent.net
AF Newbie
 
Join Date: Feb 2010
Location: Blenheim Ontario
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Re: 04 Malibu turn signal problem

My car's right turn signal would work sometimes and other times it would not work even after I replaced the bulb.
My mechanic suggested I check the light socket and I found it was corroded and the bulb was loose when I inserted it.
I cleaned it with WD40 and took a very small screw driver and pryed the contacts together just a little bit. Make sure the power is off of course.
Since then the light has worked every time.
jdapthorp@kent.net is offline   Reply With Quote
Old 02-14-2010, 10:39 AM   #23
Jetex
AF Newbie
 
Join Date: Mar 2009
Location: Bardstown, Kentucky
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

Rapid flashing of the turn signal on my 04 Malibu has in each case turned out to be bad contacts in the bulb holders. I seem to have solved the problem by spraying WD-40 into the holders. The problems were also intermittent.
Jetex is offline   Reply With Quote
Old 02-14-2010, 11:04 AM   #24
jd-autotech
AF Regular
 
Join Date: Dec 2005
Location: braidwood, Illinois
Posts: 368
Thanks: 0
Thanked 3 Times in 3 Posts
Re: 04 Malibu turn signal problem

tsb (technical service bullentin) #06-08-42-004 pretains to bulb and socket replacement search the web or have the dealer pull it up. i would ppost you a link but i cant due to copyright agreement.
jd-autotech is offline   Reply With Quote
Old 02-14-2010, 01:47 PM   #25
Hark
AF Newbie
Thread starter
 
Join Date: Jan 2006
Location: L, Illinois
Posts: 69
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

yep - still have the problem - since it is intermittent never wasted money taking it to dealer - i can try the suggestions but it doesn't seem likely. When this all started the wiring was traced all the way and nothing found and replaced the hazard switch with no result. Strange but true - when the turn signal doesn't work - I shut off the car and restart it and the turn signal works fine - so it seems more computer than bulb or wiring?
Hark is offline   Reply With Quote
Old 02-15-2010, 05:24 AM   #26
Jetex
AF Newbie
 
Join Date: Mar 2009
Location: Bardstown, Kentucky
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

As I said, I seem to have solved the problem by spraying WD-40 onto the bulb and socket contacts. I did this some 2 years ago and have had no problems since. I think there is some oxidization of the contacts going on here. It doesn't matter what brand of bulb you buy they all seem to be made in China. Maybe China is running out of lead for the contacts?
Jetex is offline   Reply With Quote
Old 06-02-2010, 09:25 AM   #27
ssfowler8
AF Newbie
 
Join Date: Jun 2010
Location: Burgettstown, Pennsylvania
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

Since I bought my Malibu used, I have had problems with the left turn signal. After several visits to the dealership and several light bulbs later. I found the problem myself. Good thing we pay the dealerships to do nothing. Found that there was no connection in the light socket and after several different attempts, I placed a small nail, yes a nail, in the socket to hold the bulb securely. After all of the money that I spent at the dealership I could've bought 2 new headlight assemblies. I have had the nail in the socket for about a year now and no problems.
ssfowler8 is offline   Reply With Quote
Old 09-23-2017, 06:08 AM   #28
CentralNYGuy
AF Newbie
 
Join Date: Sep 2017
Location: Rome, New York
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 04 Malibu turn signal problem

Hark - I know this is a very old thread, but were you ever able to find out the problem? I currently have the same exact problem on my 04 Malibu and no one knows what's going, on including the GM dealer in my area. They ran a complete diagnostics on the car and they say nothing appears to be wrong and there are no fault codes in the computer. I also brought it to an auto electrical specialist and he wouldn't even mess with it. He said " Sounds like a real headache " My problem started when I installed a new pair of plastic headlamps, because the old ones were all whited out from the sun. I thought that was the problem, so I sent them back and the company sent me a new pair. I installed those and I still have the same problem. I also tried contacting one of these GM techs you pay a fee to online. So far, none of them have been able to help. I'm at the end of my rope with this car and don't know what the heck to do with it anymore.
CentralNYGuy is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Malibu

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:27 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts