Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Malibu
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-14-2019, 04:15 PM   #1
bheston
AF Newbie
 
Join Date: May 2004
Location: Ames, Iowa
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
2009 Malibu electrical problem, gauges and dash lights

I have an electrical issue I could use some suggestions where to look for my problem. I bought this car 6 months ago, 130K miles, about a month ago I started seeing an occasional warning message on the dash while driving, but would quickly clear itself. Power Steering and Service ESC were most common. Then I started seeing all of my gauges drop out while driving, along with error messages mentioned, low fuel, and the security light would be on.

The problem has started showing up frequently now, a couple times for extended periods of time and I have got stuck where the transmission won't shift until I stop and restart the car.

I have checked battery connections, power cable to fuse block, ground wires in engine compartment (found 3 different ones). Haven't checked starter cables but might look at those next.

Today I got a bunch of diagnostic codes to register when this happened, along with a check engine light of course. Does this list of codes that registered point someone to an area I can focus my investigation? I'm still focused on wiring problem, bad ground, corrosion, or possibly bad BCM/PCM/ECM (not sure what modules this car has that could be affected), am I on the right track?

Codes look like the CANBUS communication is effected as several different modules lost communication.

U0100 - Lost comm with ECM/PCM "A"
U0073 - Control module communication bus off
P0700 - Transmission control system (MIL Request)
P0575 - Cruise control input circuit
P0150C - ?
U0101 - Lost comm with TCM
U0121 - Lost comm with anti-lock brake system (ABS) control module
U0140 - Lost comm with body control module
U2105 - ?
C0561 - ?


Thanks for the help!
bheston is offline   Reply With Quote
Old 07-08-2019, 09:53 PM   #2
bheston
AF Newbie
Thread starter
 
Join Date: May 2004
Location: Ames, Iowa
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2009 Malibu electrical problem, gauges and dash lights

Has anyone had an issue like this before? I'm still trying to figure this one out. It might run for a week without a problem, then really act up for a couple days. I have tried to clean grounds, clean power connections under the dash where the main power comes through the firewall, seems like it helps but then problem comes back randomly.

Anyone have a battery going bad that would cause something like this? This battery holds a good charge, 12.6v with the car off, but I've heard of strange electrical issues going away after changing battery before.

Thanks
bheston is offline   Reply With Quote
Old 07-08-2019, 09:57 PM   #3
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 5,506
Thanks: 5
Thanked 147 Times in 144 Posts
Re: 2009 Malibu electrical problem, gauges and dash lights

I would have a look at the fuse box itself. I just watched a video on youtube about a Malibu with random no start issues that ended up being caused by bad pins on the fuse box where the relay plugged into. GM wasn't making the greatest cars at that time (they still don't) and it shows in the build quality.
__________________
Stealthee is offline   Reply With Quote
Old 07-20-2019, 12:11 PM   #4
bheston
AF Newbie
Thread starter
 
Join Date: May 2004
Location: Ames, Iowa
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2009 Malibu electrical problem, gauges and dash lights

I have continued to troubleshoot, taking the engine compartment fuse box apart and cleaning connections, cleaning connections and ground wires at the BCM mounted on the right side of the center console. No luck yet, still having problems.

Does anyone have a diagram showing control module locations, and ground wire locations for this car? If so that would be extremely helpful!

Thanks
bheston is offline   Reply With Quote
Old 07-20-2019, 12:41 PM   #5
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,592
Thanks: 14
Thanked 327 Times in 321 Posts
Re: 2009 Malibu electrical problem, gauges and dash lights

To properly check the battery , you need to do a load test.
__________________
maxwedge is online now   Reply With Quote
Old 08-08-2019, 10:12 PM   #6
bheston
AF Newbie
Thread starter
 
Join Date: May 2004
Location: Ames, Iowa
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2009 Malibu electrical problem, gauges and dash lights

Battery was load tested and tested good. I had an alternator go bad and replaced the alternator, along with the main wire going from alternator to starter, as it was rubbed part way through on a bracket it was tied to. Hoping this would resolve my problems, but didn't change anything.

Everything I read about this type of problem on other websites people make multiple trips to the dealer, they do random things like replace cables, battery, throttle body, pedal sensor, etc, and the problem always comes back until the owner gets mad and trades off the car. I can't find anyone who has resolved this kind of problem.

I'm leaning towards it being a problem in one of the modules. Does anyone know what modules I can replace without having a dealer program them? And which ones would I need a dealer to program after I replace? What if I get a set of modules from a junk yard and put them all in as a set, does that work?
bheston is offline   Reply With Quote
Old 08-09-2019, 06:11 AM   #7
wpbharry
AF Regular
 
Join Date: Feb 2004
Location: Charlotte, North Carolina
Posts: 399
Thanks: 0
Thanked 1 Time in 1 Post
Re: 2009 Malibu electrical problem, gauges and dash lights

This generation of Malibu ('08-'12) is closely connected to the prior one ('04-'07), the latter of which I am VERY familiar with. This issue cropped up fairly frequently with that gen and it was most always a BCM going bad. Sorry to say, the solution was usually to dump the car. Avoid the newer generation '13s (first year) because they also have a slew of (different) problems.
wpbharry is offline   Reply With Quote
Old 08-15-2019, 08:44 PM   #8
bheston
AF Newbie
Thread starter
 
Join Date: May 2004
Location: Ames, Iowa
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2009 Malibu electrical problem, gauges and dash lights

Some of my research pointed to the BCM being a common failure that would cause this kind of behavior, so today I picked one up at the salvage yard for $50. I stopped by the GM dealer and installed it in the parking lot, then had the dealer program it. They tried, but their tools would not let it be reprogrammed. They printed out a paper that showed that once a VIN or odometer reading was programmed into the BCM it cannot be changed. So used BCM is useless for this car.

Even so, I could run the car with the used BCM, it just activated the theft lock so my radio didn't work, it showed "locked" on the display. I didn't notice anything else that didn't work. While running the used BCM I experienced the same problem, so I think it is safe to say the BCM wasn't the problem.

I don't think this is the cause of my problem, but the negative battery terminal doesn't tighten down as tight as I would like to see, I might swap a battery from another vehicle and replace the negative cable just to completely rule it out.

Next steps might be tracing more wiring harnesses to see if I can find any damage or corrosion on pins, but I've covered this pretty well already and haven't found anything. Other ideas welcome, thanks!
bheston is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
communication, dash, electrical, gauges
Go Back   Automotive Forums .com Car Chat > Chevrolet > Malibu

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:05 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts