Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Malibu
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-29-2017, 07:01 PM   #1
puffdaddy
AF Newbie
 
Join Date: Sep 2005
Location: Charlotte, North Carolina
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

I am trying to repair a 2000 Malibu for a young girl at our church. She purchased gas a week ago and after a little while it died. I can hear the fuel pump initialize when you turn the key on. After it sits for about 2 to 3 hours it will start and run for around 5-7 minutes then dies. Replaced the fuel filter and the gas that came out of it had a black tint to it. Thought that was the problem but after starting it up in ran for 7 minutes and died again. When you try to start it back up it tries to run then then if you keep cranking it the fuel and the gauge below it go dead. Once you turn the key off and back on they work again. Checked the fuel pressure regulator and no gas in vacuum line. Not sure where to go next but I am waiting to see if there was a problem with the gas at the place she filled up as this all started after her fill up.


REPAIRED!!!! SEE BELOW!!!!

Last edited by puffdaddy; 08-09-2017 at 08:16 PM. Reason: Repaired
puffdaddy is offline   Reply With Quote
Old 07-29-2017, 07:38 PM   #2
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,016
Thanks: 3
Thanked 254 Times in 250 Posts
Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

The most effective step would be to connect a fuel pressure gauge and monitor pressure during the prime cycle AND while cranking/running.

My gut feeling is that if the fuel was really contaminated it may be plugging the inlet screens of the injectors.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 07-30-2017, 10:23 AM   #3
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,592
Thanks: 14
Thanked 327 Times in 321 Posts
Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

Just to add, could be the sock on the fp pick up clogged if in fact the tank is contaminated.
__________________
maxwedge is online now   Reply With Quote
Old 07-30-2017, 11:32 AM   #4
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

As for the gas, could just be coincidence that this took place after a fill up.....

I agree with Blue...get a fuel gauge on this, and monitor pressure when it won't start/run....could be a fuel pump on the way out....
Tech II is offline   Reply With Quote
Old 07-31-2017, 12:43 PM   #5
puffdaddy
AF Newbie
Thread starter
 
Join Date: Sep 2005
Location: Charlotte, North Carolina
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

An update...put a pressure gauge on it and when it stopped running the pressure jumped a little and then stayed at the normal reading of around 50 psi. While the car was running it was stable, and when the vacuum line was removed from the pressure regulator the pressure jumped a little and went back down when it was placed back on. Tried using starting fluid and it would not start. Also found some additional information that the car has had its instrument panel gauges and lights go crazy a couple of times. I am still looking for some help.
puffdaddy is offline   Reply With Quote
Old 07-31-2017, 10:02 PM   #6
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

Pump looks ok....check for spark?
Tech II is offline   Reply With Quote
Old 08-01-2017, 09:48 AM   #7
puffdaddy
AF Newbie
Thread starter
 
Join Date: Sep 2005
Location: Charlotte, North Carolina
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

Third day of troubleshooting. Leaning towards the Pass lock system. When it cuts off there is no power to the injectors. Going to check electrical readings, do a Pass lock Relearn procedure and blow out the ignition key hole with WD40 and Canned Air.

Did all the above. All electrical readings looked OK after it stalled. Did a Pass lock bypass and that didn't help. Not sure if the ignition module for the key is defective or not. Is there a possibility that there is an issue with the coil packs or the controller that hooks to them? Tomorrow will be the fourth day.

Last edited by puffdaddy; 08-01-2017 at 05:46 PM.
puffdaddy is offline   Reply With Quote
Old 08-03-2017, 12:02 AM   #8
Tech II
AF Fanatic
 
Join Date: Jul 2011
Location: Worcester, Massachusetts
Posts: 5,017
Thanks: 70
Thanked 617 Times in 609 Posts
Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

All injectors are powered by the f/p-injr fuse(15a).....they are grounded by the PCM....the fuse is only powered in run and start position.....
Tech II is offline   Reply With Quote
Old 08-04-2017, 02:21 PM   #9
puffdaddy
AF Newbie
Thread starter
 
Join Date: Sep 2005
Location: Charlotte, North Carolina
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

Replaced the Ignition Key switch and the Key assembly. Car started and ran for over 12 minutes so I decided to determine which of the two parts were causing the failure. After trying to do them each I put the new parts back in and still could not get it to start. I spent a lot of time because each time I replaced one of the parts I had to wait at least 10 minutes with the key on and battery got weak so I will go back tomorrow charge the battery and start again.

Plan: try if with the new parts in it and if it starts see how long it will run. If it keeps running them will leave new parts in and take it for a drive. I also have a camshaft position sensor in case that is also part of the problem.

Update: car started and ran for 10 minutes and then shut down again. Put the original parts back on and am now researching additional problems. Saw that sometime the Camshaft position sensor could cause this and not throw any code. Is there a way to trouble shoot this sensor?
It also had the following trouble codes: P0446, P0443, & P0449. All of these are Emission codes and could they cause it to stop running after 5 to 7 minutes?

Last edited by puffdaddy; 08-05-2017 at 02:58 PM.
puffdaddy is offline   Reply With Quote
Old 08-09-2017, 08:13 PM   #10
puffdaddy
AF Newbie
Thread starter
 
Join Date: Sep 2005
Location: Charlotte, North Carolina
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Talking Re: 2000 Malibu - fuel pump ok, filter new, pressure regulator is ok

Car is finally repaired. It was the Crank Shaft Position sensor on the rear lower engine. After it stalled this morning I disconnected it and the resistance between the 2 connector pins was OPEN. Should have been reading 300 to 1000 ohms. Later when it had cooled down about three hours later the resistance was reading 1000 ohms. Replaced the sensor and now the car runs OK. The three codes dealing with the emission turned out to be cause by a bad fuel cap.
puffdaddy is offline   Reply With Quote
Old 08-09-2017, 08:15 PM   #11
puffdaddy
AF Newbie
Thread starter
 
Join Date: Sep 2005
Location: Charlotte, North Carolina
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
REPAIRED!!! 2000 Malibu - fuel pump ok, filter new, pressure r is ok

Repaired see previous post.
puffdaddy is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Malibu

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:59 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts