Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Geo > Nova | Prizm | Spectrum | Sprint
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-26-2010, 02:23 PM   #1
foster38
AF Newbie
 
Join Date: May 2010
Location: burlington, Washington
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
92 geo, under load no power

i thought i blew head gasket but the car starts and idles all day. i can rev it up by hand and it purrs, but when i put in gear and try to drive it misses and wants to die. no power under load
foster38 is offline   Reply With Quote
Old 04-07-2011, 06:44 PM   #2
Scott46550
AF Newbie
 
Join Date: May 2009
Location: Nappanee, Indiana
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 92 geo, under load no power

Try the ignition coil.
Scott46550 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Geo > Nova | Prizm | Spectrum | Sprint

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:35 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts