Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Jimmy
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 06-15-2005, 04:02 PM   #1
NOVA71
AF Regular
 
NOVA71's Avatar
 
Join Date: Jun 2005
Location: Chevy Thunder
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
engine has slight shake when idling

Hi there, I am new to this site...but gonna give this a try..Hope someone out there can give me some ideas that I havent thought of yet for fixing my 2000 gmc jimmy sle.I just bought it, and it has a slight quiver or shake when it is sitting at idle. The truck runs great otherwise, and I just changed all the plugs, the wires and the cap and rotor button, but I still seem to have the same small shake. Its not a constant shake, just every 5-10 seconds. Tomorrows job is the fuel filter and the pvc valve to see if that helps...anyone have any other ideas I'd really appreciate it. Up here in Canada we have no autozone for free code reading (as I see on some of the posts) and to take it to the dealer is 75 bucks for the first half hour (they milk ya for about an hour and a half I'm told and that is just for the scan, no work) Thanks everyone!
NOVA71 is offline   Reply With Quote
Old 06-16-2005, 05:52 AM   #2
rlith
AF Enthusiast
 
rlith's Avatar
 
Join Date: Jun 2003
Location: Pittsburgh, Pennsylvania
Posts: 3,549
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to rlith Send a message via MSN to rlith
Re: engine has slight shake when idling

Have you checked the motor mounts? Check EVERY SINGLE vac line from the intake out for dry rot and cracks as well. Is an SES light being set?
__________________


95 s10 Blazer, EGR Mod, ZQ8 Steering box mod, 99 Center console shifter mod and more... See everything at www.pghconsulting.net/teal
rlith is offline   Reply With Quote
Old 06-16-2005, 11:39 AM   #3
NOVA71
AF Regular
Thread starter
 
NOVA71's Avatar
 
Join Date: Jun 2005
Location: Chevy Thunder
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
Idle shake

Hi thanks for your reply..No SES light on, motor mounts are fine. And vac lines look to be in good shape. I dont see any signs of dry rot at all.Engine idles at 600rpm, and idles smooth for about 5 seconds. Then it gives a little shake, and smooths out again. This occurs only when sitting at idle, not while driving. Its more annoying than anything else...kinda feels like it wants to stall, but it hasnt yet. Any other ideas?
NOVA71 is offline   Reply With Quote
Old 06-16-2005, 08:48 PM   #4
JimmySLS
AF Regular
 
JimmySLS's Avatar
 
Join Date: Feb 2005
Location: Saginaw, Michigan
Posts: 106
Thanks: 0
Thanked 1 Time in 1 Post
Re: engine has slight shake when idling

I have a 97 that has this same problem..I have replaced all the vacuum lines and checked the engine mounts and I still can't figure this one out..I just learned to live with it..The vehicle runs and drives great just has a little rough idle..Have talked to a couple of buddies that are mechanics and they have said it is common for these vehicles..
JimmySLS is offline   Reply With Quote
Old 06-17-2005, 02:11 PM   #5
NOVA71
AF Regular
Thread starter
 
NOVA71's Avatar
 
Join Date: Jun 2005
Location: Chevy Thunder
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
OK, I caved in. I booked an appointment at the local dealer as much as I didn't want to. The shaking has gotten worse and the engine light is on now. I put a vac. gauge on it and it reads 19 inches of vac. Idles at 600rpm which drops to about 500rpm and the oil pressure gauge drops in accordance with the engine shake (it almost sounds like a little miss). Any more ideas before I take this to the dealer next week and have them take all my money?
NOVA71 is offline   Reply With Quote
Old 06-17-2005, 02:33 PM   #6
rlith
AF Enthusiast
 
rlith's Avatar
 
Join Date: Jun 2003
Location: Pittsburgh, Pennsylvania
Posts: 3,549
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to rlith Send a message via MSN to rlith
Re: engine has slight shake when idling

before taking it to the dealer, stop by advance autoparts and have them scan the code (don't clear it unless you actually fix it) and let us know what it is.
__________________


95 s10 Blazer, EGR Mod, ZQ8 Steering box mod, 99 Center console shifter mod and more... See everything at www.pghconsulting.net/teal
rlith is offline   Reply With Quote
Old 06-17-2005, 02:49 PM   #7
blazee
Problem?
 
blazee's Avatar
 
Join Date: Dec 2004
Location: Florida
Posts: 6,236
Thanks: 61
Thanked 110 Times in 90 Posts
Re: engine has slight shake when idling

Have you replaced the fuel filter and PCV valve, yet? Also replace the air filter.

You can try cleaning the EGR valve, too.

One of the most common causes of rough idle and missing is sticking or clogged poppit valve on the injectors. Techron fuel additive works best for cleaning them.
blazee is offline   Reply With Quote
Old 06-23-2005, 04:19 AM   #8
NOVA71
AF Regular
Thread starter
 
NOVA71's Avatar
 
Join Date: Jun 2005
Location: Chevy Thunder
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

OK had the truck on the scanner and it had 1 code in its history. Miss fire on cylinder 3. They cleared the code. Told me to replace the distributer cap, wires, and plugs. I told them I already did. They told me to run some injector cleaner through next time I get gas. I told them I already ran 2 bottles through. They told me to take the truck home and see if it clears up on its own and if it get worse call and let them know.
Oh well, I guess I'll just have to get used to it idling with a little shake.

SHAKE SHAKE SHAKE - SHAKE YOUR BOOTY !!!
NOVA71 is offline   Reply With Quote
Old 06-23-2005, 06:50 AM   #9
blazee
Problem?
 
blazee's Avatar
 
Join Date: Dec 2004
Location: Florida
Posts: 6,236
Thanks: 61
Thanked 110 Times in 90 Posts
Re: engine has slight shake when idling

What kind of injector cleaner did you use?
blazee is offline   Reply With Quote
Old 06-23-2005, 02:56 PM   #10
NOVA71
AF Regular
Thread starter
 
NOVA71's Avatar
 
Join Date: Jun 2005
Location: Chevy Thunder
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
Question

I used STP concentrated mixed in with only about 1/2 tank of gas. Sorry looked for techron but I couldn't find any in Canada. No, free code reading either. No advance autoparts stores. I was thinking about having a professioal injector cleaning done but that would cost about $120. I would do it if I was sure that it would fix the problem.
__________________


Current Rides:
1971 Nova
2004 Tracker
2013 Sonic

Past Rides:
2007 G5
1984 Firebird
2000 Jimmy
1994 Jimmy
1990 Tracker
1985 Jimmy
NOVA71 is offline   Reply With Quote
Old 06-29-2005, 08:22 PM   #11
redwheeler
AF Regular
 
redwheeler's Avatar
 
Join Date: Jan 2005
Location: de pere, Wisconsin
Posts: 182
Thanks: 0
Thanked 0 Times in 0 Posts
Re: engine has slight shake when idling

use sea foam
__________________
and yes i am a ASE Master Auto Technician

1996 chevrolet silverado 5.7L 4x4
nothin but a k&n for now i just got it
redwheeler is offline   Reply With Quote
Old 07-14-2005, 04:49 AM   #12
NOVA71
AF Regular
Thread starter
 
NOVA71's Avatar
 
Join Date: Jun 2005
Location: Chevy Thunder
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
OK, I've been gettin used to the little shake. I have found that it comes and it goes. However, it seems like it does it more after I put gas in the tank. I'm thinkin maybe there's dirt in the tank that's gettin stirred up or it has something to do with the pressure in the tank being released when the cap is removed??? I got a hold of some Techron injector cleaner and that is in my tank now. We'll see how that works out.
__________________


Current Rides:
1971 Nova
2004 Tracker
2013 Sonic

Past Rides:
2007 G5
1984 Firebird
2000 Jimmy
1994 Jimmy
1990 Tracker
1985 Jimmy
NOVA71 is offline   Reply With Quote
Old 07-14-2005, 06:14 AM   #13
b1gs3xy
AF Newbie
 
b1gs3xy's Avatar
 
Join Date: Jun 2005
Location: White Bear Lake, Minnesota
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to b1gs3xy Send a message via Yahoo to b1gs3xy
Re: engine has slight shake when idling

I had the same problem, I have a 95 4.3 vortec, and I found out that my CPI Unit was leaking and causing a miss. I am not 100% sure but I was told when your cpi leaks it can cause a cylinder to miss. I am not sure what kind of injection you have, so this may not apply to your jimmy.
b1gs3xy is offline   Reply With Quote
Old 07-14-2005, 06:30 AM   #14
blazee
Problem?
 
blazee's Avatar
 
Join Date: Dec 2004
Location: Florida
Posts: 6,236
Thanks: 61
Thanked 110 Times in 90 Posts
Re: Re: engine has slight shake when idling

Quote:
Originally Posted by b1gs3xy
I had the same problem, I have a 95 4.3 vortec, and I found out that my CPI Unit was leaking and causing a miss. I am not 100% sure but I was told when your cpi leaks it can cause a cylinder to miss. I am not sure what kind of injection you have, so this may not apply to your jimmy.
Doesn't apply, GM changed to the CSFI for 96+. The CSFI doesn't have problems with leaking like the CPI did. The CSFI is notorious for the poppit valves clogging, though. GM finally came up with a MFI that people can upgrade to.
blazee is offline   Reply With Quote
Old 11-02-2005, 01:58 PM   #15
NOVA71
AF Regular
Thread starter
 
NOVA71's Avatar
 
Join Date: Jun 2005
Location: Chevy Thunder
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
This was a long time coming. I was reading what BlazerLt had posted and decided to try giving the throttle body a good cleaning. Well I got my old tooth brush and a can of throttle body cleaner and held the throttle wide open (with the engine off of course) and went to town cleaning. Man the blackish/brown shit I cleaned off the inside of the throttle body was unbelievable. I cleaned everything I could reach with my tooth brush and then gave it a good spray clean with the throttle body cleaner. When I went to start her up, she didn't want to start. After 3 cranks or so she fired up, ran a little crappy, then smoothed out. Took her for a spin and now she seems to idle almost perfect (knock on wood). 100% improvement because lately she was idling very rough. I was thinking anytime now she is going to stall and that would be it. Now she idles almost as smooth as silk.

I've seen someone on here rig up a filter in line with the pvc valve that removes all the contaminated oil/gas from re-entering the intake system. Did anyone else try this? And would this help keep this trucks running smoother? I may just try this when I get the time.
__________________


Current Rides:
1971 Nova
2004 Tracker
2013 Sonic

Past Rides:
2007 G5
1984 Firebird
2000 Jimmy
1994 Jimmy
1990 Tracker
1985 Jimmy
NOVA71 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > GMC > Jimmy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:32 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts