Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Club Wagon
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-12-2010, 12:43 AM   #1
chadteetzen
AF Newbie
 
Join Date: May 2010
Location: fayetteville, Arkansas
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Smog pump supper heats engine.

got a new van. The van is a 1991 Club Wagon Ford. 5.8L V8.
it ran but was smelly and loud in cab when i got it. Took off dog house noticed a hose wasn't connected. Noticed that the hose had some burnt away area's of it and the smog pump type thing was melted. So i bought a new smog thing. Got new hoses. Hooked them all up so the system was air tight. Took it out for a spin. Working great for first 5 minutes. Then went up a hill. Heard almost a water boiling type sound. then you could feel heat just rush out from under the dog house and the van lost a little power. Unhooked the hose that goes to all that stuff and it's running ok now. just hard to breath in the cab and still doesn't have as much power. God any idea's on this? It's dark outside but i'm guessing my new smog pump is melted again. And i'm guessing this is why the original one got melted and why all the hoses running to it where burnt. here is a link to this smog thing i'm talking about.
http://www.rockauto.com/catalog/moreinfo.php?pk=943273
Thanks!
chadteetzen is offline   Reply With Quote
Old 03-01-2011, 04:55 PM   #2
rhandwor
AF Enthusiast
 
Join Date: Sep 2006
Location: Athens, Georgia
Posts: 4,629
Thanks: 0
Thanked 62 Times in 62 Posts
Re: Smog pump supper heats engine.

If you have it removed use a vacuum pump and flashlight make sure the piston in side is moving before purchasing a new unit.
rhandwor is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Club Wagon

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:03 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts