Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mazda > 929/Sentia
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-22-2011, 11:24 AM   #1
automan9482
AF Regular
 
Join Date: Jan 2005
Location: Indianapolis, Indiana
Posts: 132
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via Yahoo to automan9482
HELP! '92 929 coolant circ. problem/no heat!!

'92 929 3.0 V6 A/T 122K sat for a few months undriven, and now it has no heat. The temp gauge goes a little above half way in the norm. range, but the bottom hose isn't getting hot, like the thermostat is not opening. Replaced the thermostat last night to no avail....The gauge goes up between half and the upper part of the normal range, but there's still no heat, and the lower radiator hose does not warm up at all. The top hose gets hot as hell, and eventually the coolant burps back out the top of the radiator cap opening....I've been squeezing both upper and lower hoses with the cap off and the car running to try to bleed it, until it gets hot enough for the coolant to start coming out, but it isn't working. Is there a bleeder somewhere I am missing, or some trick to get this cooling system to circulate right? I am thinking water pump..maybe..but it seems to be circulating, just air locking at the bottom hose/thermostat.
PLEASE HELP!!!!
automan9482 is offline   Reply With Quote
Old 02-15-2012, 12:49 PM   #2
osjohn1
AF Newbie
 
Join Date: Feb 2012
Location: Nashville, Tennessee
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: HELP! '92 929 coolant circ. problem/no heat!!

929 Mazda (1992) No Heat But A/C Works
I have a 929 Mazda 1992 year. Does not blow any heat. I noted that the 30 amp fusible link for the heater was busted. Replaced it but still no heat. A busted fuse means an electrical overload occurred somewhere, what do I need to look at to I.D. the problem?

I have change a little heat filament up inside the blower and I have changed the heater control unit on the dashboard.

My suspect the heater core but I need some help before I full this care apart.
The heater core blows air. The heater core blows when the A/C works. When the heater is turned on it just blows cold air. This means that the motor on the heater core is working.
All of this make me think that no coolant from the engine is not reaching the heater core. I tried to find the heater valve but could not find it. I was thinking that this valve is closes and is not allowing the hot coolant to get to the heater core.
If the heater core is blocked or not getting any coolant, what are my options?
Both the top and bottom radiator hoses get hot as they supposed to which means that the thermostat is working.
osjohn1 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater error problem-No heat 1993cherokee Grand Cherokee | Grand Cherokee SRT8 7 01-10-2007 02:49 PM
HVAC Problem, No Heat, Water on Floor GeorgePM Grand Cherokee | Grand Cherokee SRT8 5 02-10-2005 05:08 AM
Low coolant light and no heat related? GTackett Trans Sport 9 02-09-2005 09:04 AM
Low coolant light and no heat related? GTackett Montana/Montana SV6 2 02-02-2005 07:06 AM
Low coolant light and no heat related? GTackett Venture 2 01-28-2005 03:07 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mazda > 929/Sentia

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:04 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts