Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Corvette
Corvette
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-14-2011, 02:17 PM   #1
cajunboyla
AF Newbie
 
Join Date: Mar 2007
Location: Moffett Field, California
Posts: 32
Thanks: 2
Thanked 0 Times in 0 Posts
C4 Cluster problem

Okay guys; need help... My 84 C4 instrument cluster has gone haywire. As soon as I turn the key it starts flashing erratically...like its on display. Not providing any information on engine\or any other functions. Is this a electrical nightmare or a simple change of component?

vr
cajunboyla
cajunboyla is offline   Reply With Quote
Old 10-18-2011, 02:04 PM   #2
Rimmer
AF Newbie
 
Join Date: Apr 2007
Location: Sonoma. Calif., California
Posts: 46
Thanks: 0
Thanked 2 Times in 2 Posts
Re: C4 Cluster problem

Possibly a bad ground?
Rimmer is offline   Reply With Quote
The Following User Says Thank You to Rimmer For This Useful Post:
cajunboyla (10-20-2011)
Old 10-18-2011, 02:37 PM   #3
cajunboyla
AF Newbie
Thread starter
 
Join Date: Mar 2007
Location: Moffett Field, California
Posts: 32
Thanks: 2
Thanked 0 Times in 0 Posts
Re: C4 Cluster problem

Thanks Rimmer; gives me a point of reference to begin with...
cajunboyla is offline   Reply With Quote
Old 10-19-2011, 09:49 AM   #4
Blackcrow64
AF Moderator
 
Blackcrow64's Avatar
 
Join Date: Jun 2002
Location: Salem, Ohio
Posts: 9,611
Thanks: 52
Thanked 24 Times in 23 Posts
Re: C4 Cluster problem

It's hard to say with something like that... Have you changed anything recently that would directly affect the cluster?
__________________
-Brian
  • 92 Firebird sold
  • 97 Talon TSI AWD sold
  • 05 Cobalt LS sold
  • 02 Tahoe LT sold
  • 06 Cadillac STS4 AWD sold
  • 03 Corvette Z06
  • 14 Silverado 1500
Blackcrow64 is offline   Reply With Quote
The Following User Says Thank You to Blackcrow64 For This Useful Post:
cajunboyla (10-20-2011)
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
'99 GP/GT Instrument Cluster Problem USARet1995 Grand Prix 6 04-21-2009 10:47 PM
gauge cluster problem myeclipseisnicer '92-'95 Civic | EL | Civic Hybrid | Civic GX NGV 9 09-08-2003 12:15 AM
2000 740il instrument cluster problem musclecar neal 7 Series 7 03-11-2003 11:47 PM
Guage Cluster problem h82lose '92-'95 Civic | EL | Civic Hybrid | Civic GX NGV 2 06-24-2002 11:12 PM
SiR guage cluster problem 13secondcivic '71-'87 Civic | CRX 1 02-16-2002 01:52 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Corvette

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:21 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts