Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
Become a fan of Igor Sushko - Racecar Driver
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Silverado
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 04-08-2012, 10:11 PM   #1
david8465
AF Newbie
 
Join Date: Apr 2012
Location: MOODY, Texas
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
2005 chevy silverado 4wd problems

Hi everyone,

I took my truck to the dealership and had these codes pulled: C0306, C0321, C0327 and C0379. Tech told me my encoder motor needs replacing for $700. I replaced it with an after market unit bought through monster autoparts. At first after installing the new unit the selector switch light lit up properly and I could select between A4WD 2HI 4HI and 4LO but the front axle would not engage. Now the selector switch is stuck lit on A4WD and will not change. The encoder motor makes a cycling noise like it is trying to shift between gears with the key off and out of the ignition. (does it also with the engine running) The front axle actuator will lock the front axle. Anyone have this problem? This drive 4wd system ihas been an absolute pain. any ideas? Any suggestions would be appreciated.
david8465 is offline   Reply With Quote
Old 04-09-2012, 08:01 AM   #2
MT-2500
AF - Advisor
 
MT-2500's Avatar
 
Join Date: Sep 2005
Location: New London, Missouri
Posts: 16,684
Thanks: 5
Thanked 121 Times in 120 Posts
Re: 2005 chevy silverado 4wd problems

Quote:
Originally Posted by david8465 View Post
Hi everyone,

I took my truck to the dealership and had these codes pulled: C0306, C0321, C0327 and C0379. Tech told me my encoder motor needs replacing for $700. I replaced it with an after market unit bought through monster autoparts. At first after installing the new unit the selector switch light lit up properly and I could select between A4WD 2HI 4HI and 4LO but the front axle would not engage. Now the selector switch is stuck lit on A4WD and will not change. The encoder motor makes a cycling noise like it is trying to shift between gears with the key off and out of the ignition. (does it also with the engine running) The front axle actuator will lock the front axle. Anyone have this problem? This drive 4wd system ihas been an absolute pain. any ideas? Any suggestions would be appreciated.
To many codes.
With that many cods could be transfer case computer or wiring.

What Silverado and what transfer case?
Were codes cleared and retested.
For what code popped first.
Clear codes and see what code comes back first.

To test and repair transfer case problems you will need a good transfer case scanner and some good repair info on the repair flow charts.

Not just throwing parts at it from somebodys code check.
__________________
Remember proper testing gives us the answer to many problems.
MT
MT-2500 is offline   Reply With Quote
The Following User Says Thank You to MT-2500 For This Useful Post:
david8465 (04-09-2012)
Old 04-09-2012, 08:16 AM   #3
j cAT
AF Fanatic
 
Join Date: Oct 2007
Location: EVERETT, Massachusetts
Posts: 9,928
Thanks: 1
Thanked 329 Times in 328 Posts
Re: 2005 chevy silverado 4wd problems

what is the transfercase fluid color ?
j cAT is offline   Reply With Quote
Old 04-09-2012, 08:37 PM   #4
david8465
AF Newbie
Thread starter
 
Join Date: Apr 2012
Location: MOODY, Texas
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 2005 chevy silverado 4wd problems

the blue stuff, cant think of the name of it. replaced it 18 months ago. looks good
david8465 is offline   Reply With Quote
Old 04-09-2012, 08:43 PM   #5
david8465
AF Newbie
Thread starter
 
Join Date: Apr 2012
Location: MOODY, Texas
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Re: 2005 chevy silverado 4wd problems

05 Z71 LS trim package with 5.3. the transfer case is NG-246. the service 4wd no longer pops up on the DIC with the new encoder motor on it, but does feel like the front actuator is engaged when turning. I havent cleared the codes. How is this done? Once I figure out how to clear the codes I will wait and see which codes pop up first. I did pull the 4wd fuse in the dash fuse panel and the trec fuse in the engine compartment fuse panel to stop the motor from buzzing/cycling.
david8465 is offline   Reply With Quote
Old 04-10-2012, 08:39 AM   #6
j cAT
AF Fanatic
 
Join Date: Oct 2007
Location: EVERETT, Massachusetts
Posts: 9,928
Thanks: 1
Thanked 329 Times in 328 Posts
Re: 2005 chevy silverado 4wd problems

it is possible that the encoder is not installed correctly or is defective. many have installed these wrong or had defective part. remove encoder and check for proper alignment to the engaging fork.

when this is being done recheck the wiring especially the smaller sensing wirings to report encoder position.

with one front wheel off the ground see if you can rotate it. if not the front locking actuator is locking the front axle together .

if the fluid now is still blue then there is a very good chance this is an electrical issue.
j cAT is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 chevy silverado 5.3 oil comsumption ? charlesduford Silverado 6 01-07-2011 02:13 PM
2001 Rodeo 4wd problems Derman Rodeo | Passport | MU 2 01-20-2010 08:49 PM
1995 chevy z71 instrument cluster problem BIGER_IN_TEXAS_Z71 Silverado 0 09-03-2009 04:22 PM
Programing keyless remote for 2005 Chevy Silverado swatglock Silverado 0 07-31-2005 03:49 PM
reprograming keyless entry for a 2000 chevy silverado 4wd mperkins20 C/K 2 07-21-2004 10:11 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Silverado

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:12 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
 
no new posts