Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
Become a fan of Igor Sushko - Racecar Driver
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Toyota > Highlander/Highlander Hybrid/Kluger
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-20-2012, 05:59 PM   #1
tepco
AF Newbie
 
Join Date: Feb 2007
Location: Greensboro, North Carolina
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
I fixed a Highlander 2k rpm stumble, heres how.

In case you have a stumble that occurs up to 2k rpm that is non constant, sometimes rough idle but mostly not, most noticeable at 2k but fine everywhere above that, here is how I fixed mine.

2003 Highlander 2.4l 4cyl 2wd 170k miles

Replaced the plugs (Densos lasted 70k, I replaced with NGK)
Cleaned the MAF sensor, and thats it. I was afraid it was something much bigger. Plugs looked a little lean with a small amount of build up. Runs great again.

I posted this because I wanted to remind people not to over look the simple things!
tepco is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Toyota > Highlander/Highlander Hybrid/Kluger

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:04 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
 
no new posts