Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Ninety Eight
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 01-17-2006, 02:22 AM   #1
drkcrusader
AF Newbie
 
Join Date: Jan 2006
Location: Round Rock, Texas
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to drkcrusader Send a message via MSN to drkcrusader Send a message via Yahoo to drkcrusader
Exclamation 1991 oldsmobile 98 regency elite won't start

okay, the pcv checked out fine, i changed the fuel filter, changed the oxygen sensor, all the spark plugs and wires are new, the starter is good and so is the battery. i'm out of ideas. i was told to check the fuel injectors and something about an ecu (whatever that is) and the distributor caps. um there's also a backfire from somewhere under the engine i was told that is possibly the exhaust manifold. also i was told something about checking the spark plugs with a screw driver somehow but i got confused about the procedure. anyone got any ideas or help on what i should do? i need to at least get the car able to run by tomorrow night cuz i commute to college and need to be at class. this is top priority for me. please help.
drkcrusader is offline   Reply With Quote
Old 01-17-2006, 02:55 AM   #2
80sOlds98
AF Newbie
 
Join Date: Nov 2005
Location: Seattle, Washington
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1991 oldsmobile 98 regency elite won't start

With problems like this, the more specific you can be describing the exact *symptoms* the faster you will find the answer. What *exactly* is it doing? You turn the key and:

a. It cranks but won't fire, starter sounds normal and engine turns fast but it won't run.

b. It tries to start but can't turn over, you can hear the starter trying to turn the motor but it doesn't have enough energy to turn it over all the way.

c. You hear only a "click" when the key goes to "start."

d. You hear nothing at all when the key goes to "start."

e. None of the above (please elaborate).


From what you are saying in your post, it seems the car cranks just fine but won't start. If that is indeed the case, it is either not getting fuel or not getting spark. If it's not getting fuel, it could be a bad fuel pump, fuel regulator, or an issue with the fuel rail, or it could be an electrical issue. If it's electrical, it could be the ECM (electronic control module) or one of the igntion components.

This kind of problem requires a good factory service manual to diagnose. You will need the manual that includes all of emissions diagnosis. I would suspect an electrical fault. I am not familar with this particular engine, but with other engines something like a bad crankshaft position sensor can cause a crank-but-no-start condition like what you may be experiencing.
80sOlds98 is offline   Reply With Quote
Old 01-17-2006, 01:33 PM   #3
drkcrusader
AF Newbie
Thread starter
 
Join Date: Jan 2006
Location: Round Rock, Texas
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to drkcrusader Send a message via MSN to drkcrusader Send a message via Yahoo to drkcrusader
Re: 1991 oldsmobile 98 regency elite won't start

it cranks but won't fire
drkcrusader is offline   Reply With Quote
Old 01-17-2006, 02:36 PM   #4
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,040
Thanks: 0
Thanked 260 Times in 256 Posts
Re: 1991 oldsmobile 98 regency elite won't start

Got spark? Got fuel pressure?
maxwedge is offline   Reply With Quote
Old 01-22-2006, 08:22 PM   #5
drkcrusader
AF Newbie
Thread starter
 
Join Date: Jan 2006
Location: Round Rock, Texas
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to drkcrusader Send a message via MSN to drkcrusader Send a message via Yahoo to drkcrusader
Question Re: 1991 oldsmobile 98 regency elite won't start

ok i'm totally stumped now. i replaced the fuel pressure regulator, the fuel filter, the o2 sensor, the fuel injectors and spark plugs are all firing like they should, the starter is fine, the battery is charged, the fuel pump is turning on and putting out enough pressure, the alternator is fine, the fuel line isn't blocked, all electric stuff is working, and she still isn't turning on. i'm out of ideas. i've tried everything everyone has said to do, and still nothing. anyone got any other ideas?
drkcrusader is offline   Reply With Quote
Old 01-23-2006, 10:45 AM   #6
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,040
Thanks: 0
Thanked 260 Times in 256 Posts
Re: 1991 oldsmobile 98 regency elite won't start

Spray carb cleaner in the inatke see if it fires and post back.
maxwedge is offline   Reply With Quote
Old 01-23-2006, 03:52 PM   #7
80sOlds98
AF Newbie
 
Join Date: Nov 2005
Location: Seattle, Washington
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1991 oldsmobile 98 regency elite won't start

Maybe it's flooded? Press the gas pedal all the way to the floor and hold it. Then crank the engine. This will signal the ECM to stop spraying fuel long enough to let it attempt to clear itself.

If that doesn't work, you are going to have to get a factory (not aftermarket) service manual book or CD which you really should have gotten before doing all this work. These new cars are not like the older cars we are used to working on. Even a seasoned mechanic can't mess with them without the factory manual to tell them exactly what to do!

I have a factory manual for an '89 with this same engine, I'll dig it out and see what I can find out. . .
80sOlds98 is offline   Reply With Quote
Old 01-30-2006, 06:07 AM   #8
typicalham
AF Newbie
 
Join Date: Jan 2006
Location: bronx, New York
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1991 oldsmobile 98 regency elite won't start

crank and camshaft sensors...thats it...dont bother looking elsewhere
typicalham is offline   Reply With Quote
Old 01-30-2006, 11:50 AM   #9
80sOlds98
AF Newbie
 
Join Date: Nov 2005
Location: Seattle, Washington
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1991 oldsmobile 98 regency elite won't start

Those will definitely cause a crank-but-no-start condition. Again, need factory manual to diagnose and replace!
80sOlds98 is offline   Reply With Quote
Old 02-17-2012, 09:02 PM   #10
spartch
AF Newbie
 
Join Date: Feb 2012
Location: Saint Cloud, Minnesota
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1991 oldsmobile 98 regency elite won't start

1991 Oldsmobile 98 Regency Elite stopped running, would turn but no spark, was told to replace the crankshaft sensor. Did that & since then have also replaced the camshaft sensor, the coil pack & control module, the plugs & wires. Up until today it was still the same turn but no spark, now it does not turn at all it just makes a clicking noise.... I am totally stumped, thought it could be ecm or relay... PLEASE HELP!!
spartch is offline   Reply With Quote
Old 02-18-2012, 12:02 PM   #11
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,040
Thanks: 0
Thanked 260 Times in 256 Posts
Re: 1991 oldsmobile 98 regency elite won't start

Sounds like a battery or starter issue for now, but when that is fixed check for 12v at the pink wire at the ign module, also all the fuses.
__________________
maxwedge is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Ninety Eight

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:22 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
 
no new posts