Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
Become a fan of Igor Sushko - Racecar Driver
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Sprint
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 08-19-2011, 12:35 AM   #1
reddogs52
AF Newbie
 
Join Date: Aug 2011
Location: Portland, Oregon
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Trying to figure out what's wrong...

My Grandpa recently gave me his 1988 Chevrolet Sprint. It had been sitting around since 06. But it was able to start and be driven to a local auto shop. A simple clutch and catalytic convertor (didn't pass smog) replacement was all that needed to be done. However, after they had replaced the clutch, the car would not idle for very long. The place we brought it to replace the CAT also fixed the idling issue. However, I am now noticing some major losses in gas and I can't figure out what's happening. Whenever I park on an incline, the car has trouble starting or staying on when I start up again. I was under the impression I should be seeing at least 36 mpg. I'm seeing more like 27

any ideas guys? I know the carb could be suspect, but I don't want to dish out $200 without being sure. The tires haven't been serviced in a while, but that can't lower my mpg by more than 20% in the city.
reddogs52 is offline   Reply With Quote
Old 08-21-2011, 08:43 AM   #2
shorod
SHO Off
 
shorod's Avatar
 
Join Date: Jun 2004
Location: Cedar Rapids, Iowa
Posts: 9,932
Thanks: 39
Thanked 203 Times in 196 Posts
Re: Trying to figure out what's wrong...

Welcome to the forum!

I've moved your thread to the Sprint forum as more folks there have probably encountered this problem.

Based on your description (and no experience with a Sprint) my first suspect would be the fuel pump.

-Rod
shorod is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
1982 Toro,speedometer went out, can't figure out what's wrong...please help! battlecat Toronado 6 09-21-2008 08:22 AM
Trying to figure out year and model this block was out of... ItsA88 General Discussion 7 07-22-2006 08:22 PM
Still can't figure out what's wrong!!!! darocka2001 Cavalier 14 09-09-2005 08:59 PM
Can not figure out what's wrong... TheMattHatter MR2/MR-S 13 11-15-2004 10:44 AM
Can't figure out what's wrong, it won't start!! phixion009 '88 - '91 Civic | CRX | Wagon | Shuttlee 4 09-02-2004 04:12 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Chevrolet > Sprint

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:59 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
 
no new posts