Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
Become a fan of Igor Sushko - Racecar Driver
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mazda > Millenia/Xedos 9
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 03-30-2011, 12:19 PM   #1
Oprava
AF Newbie
 
Join Date: Jul 2004
Location: Chapel Hill, North Carolina
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Millenia S 1999 P0431 code

Over the last 14 days once in a while when I stopped the car I could smell something like burnt oil while still in a car. When I opened a hood I do not see any smoke or could find an oil leak visually or by smelling. I have not noticed any excessive use of oil. Today P0431 code sprang out. Is the pre-cat about done or is it something else masquerading as a pre-cat problem? Thanks.
Oprava is offline   Reply With Quote
Old 04-01-2011, 06:28 PM   #2
adamgrant
AF Newbie
 
Join Date: Jan 2011
Location: charlottetown
Posts: 38
Thanks: 0
Thanked 1 Time in 1 Post
Re: Millenia S 1999 P0431 code

Sometimes the valve cover gaskets will leak around the the spark plug area and let oil in there, giving an oil smell and also causing a misfire which could damage the converters. The precats are built into the maniflods on millenia's. They give a rooten egg smell off if theres too much raw fuel entering them..... was there any other codes?
adamgrant is offline   Reply With Quote
Old 04-04-2011, 07:36 AM   #3
Oprava
AF Newbie
Thread starter
 
Join Date: Jul 2004
Location: Chapel Hill, North Carolina
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Millenia S 1999 P0431 code

Thanks for the response. There were no other codes. I cleared the code 4 days ago and it did not come back. There was never a smell of rotten eggs. The smell of burned oil appears irregularly. For the last 4 days no smell at all. I will check leakage of oil around the cover.
Oprava is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with my 1999 Mazda Millenia V6 2.5L IcyBob Millenia/Xedos 9 0 01-04-2010 07:04 PM
1999 - P0301 Code. Michael P. Windstar 5 10-29-2004 09:15 AM
1999 GMC code P0302 jdod85 Sierra 1 10-28-2004 08:36 AM
1999 prism code P0441 purge flow rate johnholl General Discussion 0 07-15-2004 11:28 AM
1999 blazer Code P0446 davydawg Blazer 7 06-10-2004 01:01 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mazda > Millenia/Xedos 9

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:12 PM.

Community Participation Guidelines | How to use your User Control Panel
Automotive Forums .com - Car Forums - Privacy Statement - Top

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
 
no new posts