Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
Become a fan of Igor Sushko - Racecar Driver
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Isuzu > Ascender
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-09-2009, 12:19 PM   #1
2yankeefans
AF Newbie
 
Join Date: Dec 2009
Location: ocenaside, California
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
05 ascender problems

1st-i have an 05 7psg. i am the 2nd owner. the previous owners installed a tv in the 2nd row. there are 2 led lights that stay on all the time. i can only get them to turn off if i turn on the dome light and then turn it off. then they go off but come back on later. any ideas why? and how can i fix it?
second....if it sets for more than a day the battery is completely dead and i have to hook the battery up and charge it. it also wants to stall out and die sometimes as im pulling into a parking stall or setting at a stop light. it will start back up. (new battery, cleaned the posts, checked the alternator)
and 3rd..it makes this winding sound. its loud. you can hear me coming from a mile away it seems.
ive taken it in and had 3 different people look at it and get 3 different answers. 1-tranny going out. 2-bearings in alternator going out. 3-nothings wrong
2yankeefans is offline   Reply With Quote
Old 05-08-2010, 10:50 AM   #2
vipergg
AF Enthusiast
 
Join Date: Mar 2004
Location: Rochester, New York
Posts: 560
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 05 ascender problems

The battery problem is obviously something is putting parasitic drain on the battery . I would at first suspect that device that you say you are having problems with the leds. The whining sound is most likely a bad idler pully , very common problem on all Trailblazers, Envoys, Ascenders etc... A cheap fix to have that replaced .
vipergg is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Isuzu > Ascender

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:13 PM.

Community Participation Guidelines | How to use your User Control Panel
Automotive Forums .com - Car Forums - Privacy Statement - Top

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
 
no new posts