Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online!
Become a fan of Igor Sushko - Racecar Driver
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mazda > AZ-Offroad
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 09-17-2007, 09:31 PM   #1
kelmoreau1
AF Newbie
 
Join Date: Sep 2007
Location: SASKATOOON
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Engine Problems

I have a 2002 B4000 Mazda Truck. The problem im having is when I accelerate i hear a slipping (pinging) noise coming from the engine, what could this be?
kelmoreau1 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mazda > AZ-Offroad

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:00 PM.

Community Participation Guidelines | How to use your User Control Panel
Automotive Forums .com - Car Forums - Privacy Statement - Top

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
 
no new posts